Closed Bug 1467462 Opened 2 years ago Closed 2 years ago

Bustages @test_toolkit_moz_configure.py when Gecko 62 merges to Beta on 14-06-2018

Categories

(Firefox Build System :: General, defect, blocker)

3 Branch
defect
Not set
blocker

Tracking

(thunderbird_esr52 unaffected, thunderbird_esr60 unaffected, firefox-esr52 unaffected, firefox-esr60 fixed, firefox60 unaffected, firefox61 fixed, firefox62+ verified)

VERIFIED FIXED
mozilla62
Tracking Status
thunderbird_esr52 --- unaffected
thunderbird_esr60 --- unaffected
firefox-esr52 --- unaffected
firefox-esr60 --- fixed
firefox60 --- unaffected
firefox61 --- fixed
firefox62 + verified

People

(Reporter: CosminS, Assigned: glandium)

References

Details

Attachments

(1 file)

Central as beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&revision=9aa14f567712f1e73626f9ec53ec4b17779b257d&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=running&filter-resultStatus=pending&filter-resultStatus=runnable&selectedJob=182266731

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=182266731&repo=try&lineNumber=73360

[task 2018-06-07T13:01:39.256Z] 13:01:39  WARNING - ../python/mozbuild/mozbuild/test/configure/test_toolkit_moz_configure.py::TestToolkitMozConfigure::test_developer_options TEST-UNEXPECTED-FAIL
[task 2018-06-07T13:01:39.256Z] 13:01:39     INFO - =================================== FAILURES ===================================
[task 2018-06-07T13:01:39.256Z] 13:01:39     INFO - ________________ TestToolkitMozConfigure.test_developer_options ________________
[task 2018-06-07T13:01:39.256Z] 13:01:39     INFO - self = <test_toolkit_moz_configure.TestToolkitMozConfigure testMethod=test_developer_options>
[task 2018-06-07T13:01:39.256Z] 13:01:39     INFO -     def test_developer_options(self):
[task 2018-06-07T13:01:39.271Z] 13:01:39     INFO -         def get_value(args=[], environ={}):
[task 2018-06-07T13:01:39.271Z] 13:01:39     INFO -             sandbox = self.get_sandbox({}, {}, args, environ)
[task 2018-06-07T13:01:39.272Z] 13:01:39     INFO -             return sandbox._value_for(sandbox['developer_options'])
[task 2018-06-07T13:01:39.279Z] 13:01:39     INFO - >       self.assertEqual(get_value(), True)
[task 2018-06-07T13:01:39.279Z] 13:01:39     INFO - E       AssertionError: None != True
[task 2018-06-07T13:01:39.279Z] 13:01:39     INFO - ../python/mozbuild/mozbuild/test/configure/test_toolkit_moz_configure.py:21: AssertionError
[task 2018-06-07T13:01:39.279Z] 13:01:39     INFO - =========================== 1 failed in 0.74 seconds ===========================
[task 2018-06-07T13:01:39.279Z] 13:01:39     INFO - Setting retcode to 1 from /builds/worker/workspace/build/src/python/mozbuild/mozbuild/test/configure/test_toolkit_moz_configure.py
[task 2018-06-07T13:01:39.286Z] 13:01:39     INFO - /builds/worker/workspace/build/src/python/mozbuild/mozbuild/test/frontend/test_namespaces.py
[task 2018-06-07T13:01:39.286Z] 13:01:39     INFO - ============================= test session starts ==============================
[task 2018-06-07T13:01:39.286Z] 13:01:39     INFO - platform linux2 -- Python 2.7.9, pytest-3.2.5, py-1.5.3, pluggy-0.4.0 -- /builds/worker/workspace/build/src/obj-firefox/_virtualenvs/init/bin/python
[task 2018-06-07T13:01:39.286Z] 13:01:39     INFO - rootdir: /builds/worker/workspace/build/src/python/mozbuild, inifile:

This looks to be a regression from bug 1467041 https://hg.mozilla.org/mozilla-central/rev/9f71934b9849
Flags: needinfo?(mh+mozilla)
Flags: needinfo?(mh+mozilla)
Assignee: nobody → mh+mozilla
Attachment #8984303 - Flags: review?(core-build-config-reviews) → review?(nfroyd)
Comment on attachment 8984303 [details]
Bug 1467462 - Adjust test_developer_options after bug 1467041.

https://reviewboard.mozilla.org/r/250112/#review256548
Attachment #8984303 - Flags: review?(nfroyd) → review+
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/22731d5b275a
Adjust test_developer_options after bug 1467041. r=froydnj
Comment on attachment 8984303 [details]
Bug 1467462 - Adjust test_developer_options after bug 1467041.

Approval Request Comment
[Feature/Bug causing the regression]: This fixes the tests for --enable-release after bug 1467041
[Is this code covered by automated tests?]: This code *is* an automated test
[Has the fix been verified in Nightly?]: On autoland
[Needs manual test from QE? If yes, steps to reproduce]: N/A
[List of other uplifts needed for the feature/fix]: This accompanies uplifting bug 1467041
[Is the change risky?]: No
[Why is the change risky/not risky?]: The change actually introduces tests for both nightly *and* non-nightly, proving that bug 1467041 actually works as intended on all branches, while fixing the test when running on non-nightly.
[String changes made/needed]: N/A
Attachment #8984303 - Flags: approval-mozilla-esr60?
Attachment #8984303 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/22731d5b275a
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
I've confirmed with the SV sheriffs that this is fixed in the most recent simulations.
Comment on attachment 8984303 [details]
Bug 1467462 - Adjust test_developer_options after bug 1467041.

Bug fix needed for bug 1467041. Approved for 61.0b13 and ESR 60.1.
Attachment #8984303 - Flags: approval-mozilla-esr60?
Attachment #8984303 - Flags: approval-mozilla-esr60+
Attachment #8984303 - Flags: approval-mozilla-beta?
Attachment #8984303 - Flags: approval-mozilla-beta+
Keywords: regression
Version: Version 3 → 3 Branch
You need to log in before you can comment on or make changes to this bug.