Closed Bug 14675 Opened 21 years ago Closed 20 years ago

unreachable code in mailnews/mime/cthandlers/vcard/nsVCardObj.cpp

Categories

(MailNews Core :: MIME, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: colin, Assigned: rhp)

Details

Something is amiss with this code fragment from
mailnews/mime/cthandlers/vcard/nsVCardObj.cpp

        while (*p) {
                if (*p & 0x80)
                        return PR_TRUE;
                else
                        return PR_FALSE;
                p++;
        }

You can never reach the p++ statement!!

Colin.
Status: NEW → ASSIGNED
Target Milestone: M11
Good catch. The "else" clause shouln't be there. I'll check this in when
the tree opens.

- rhp
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
This was bad code that should now be fixed. Thanks again for catching this.

- rhp
I can't take the credit. It was the OpenVMS compiler who found it :-)

Colin.
colin - would you mind being the QA contact and verifying the "fix" when you do
a build next?  Thanks.
Sure, no problem. Will be a few days at least though, as I'm working on M10
right now. Hmm, so long as nothing else has changed in that file, I could
include it in my M10. Wouldn't do any harm, and it might fix something!
Status: RESOLVED → VERIFIED
I just pulled the new code and the compiler didn't grumble.

This one is verified.
Thanks for the quick response and turnaround!
Status: VERIFIED → REOPENED
In rev 1.10 we have regressed and the problem is back. The "else" clause is back
in again!!!
Resolution: FIXED → ---
Clearing FIXED (since its not any more).
Status: REOPENED → ASSIGNED
Ahh, yes. I had to drop back to some 4.x code. Sorry about that and I'll fix
this.

- rhp
Status: ASSIGNED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → FIXED
Fixed this one...again :-)

- rhp
colin - can you verify again?  thanks.
Status: RESOLVED → VERIFIED
Yep, its fixed again.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.