Set default toolbox host type if the host type preference value is unexpected. (e.g. the "side")

RESOLVED FIXED in Firefox 62

Status

defect
P3
normal
RESOLVED FIXED
Last year
Last year

People

(Reporter: mantaroh, Assigned: mantaroh)

Tracking

({regression})

unspecified
Firefox 62
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 unaffected, firefox62+ fixed)

Details

Attachments

(1 attachment)

If we update Nightly 2018-06-07, the "side" value of devtools.toolbox.host is unexpected value, as result of it, we can't open the devtools.

STR:
 1) Open devtools in side bar
 2) Update Nightly to 2018-06-07.
 3) After updating Nightly, open devtools.

AR: can't open the devtools. (In toolbox-host-manager.js:147, throw the exception)

ER: devtools is opened.

I think that we might need to set the default value if the preferences value is unexpected value.[1]

[1] https://searchfox.org/mozilla-central/rev/c621276fbdd9591f52009042d959b9e19b66d49f/devtools/client/framework/toolbox-host-manager.js#46
Comment hidden (mozreview-request)

Comment 2

Last year
mozreview-review
Comment on attachment 8984343 [details]
Bug 1467679 - Restore the devtools.toolbox.host value if this value is unexpected.

https://reviewboard.mozilla.org/r/250158/#review256542

::: devtools/client/framework/toolbox-host-manager.js:48
(Diff revision 1)
>    this.frameId = ID_COUNTER++;
>  
>    if (!hostType) {
>      hostType = Services.prefs.getCharPref(LAST_HOST);
> +    if (!Hosts[hostType]) {
> +      // If the preferences value is unexpected, restore to the default value.

s/preferences/preference
Attachment #8984343 - Flags: review?(gl) → review+
Duplicate of this bug: 1467760

Comment 4

Last year
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/120a4d4dced8
Clear the devtools.toolbox.host value if this value is unexpected. rgl
Backed out changeset 120a4d4dced8 (bug 1467679) for Devtools failure on devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js. CLOSED TREE

Log:
https://treeherder.mozilla.org/logviewer.html#?job_id=182521983&repo=mozilla-inbound&lineNumber=1714
INFO TEST-PASS | devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js | Found the correct number of debugger panes. -
15:05:12     INFO -  212 INFO Destroying the specified debugger.
15:05:12     INFO -  213 INFO Waiting for event: 'Debugger:Shutdown' on [object ChromeWindow].
15:05:12     INFO -  214 INFO Waiting for event: 'destroyed' on [object Object].
15:05:12     INFO -  215 INFO Console message: [JavaScript Error: "NS_ERROR_FAILURE: " {file: "chrome://devtools/content/debugger/debugger-view.js" line: 744}]
15:05:12     INFO -  216 INFO Removing tab.
15:05:12     INFO -  217 INFO Tab removed and finished closing.
15:05:12     INFO -  218 INFO Initializing a debugger panel.
15:05:12     INFO -  219 INFO Adding tab: about:blank
15:05:12     INFO -  220 INFO Loading frame script with url chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/code_frame-script.js.
15:05:12     INFO -  221 INFO Tab added and finished loading: about:blank
15:05:12     INFO -  222 INFO Debugee tab added successfully: undefined
15:05:12     INFO -  Buffered messages logged at 15:05:12
15:05:12     INFO -  223 INFO Debugger panel shown successfully.
15:05:12     INFO -  Buffered messages finished
15:05:12    ERROR -  224 INFO TEST-UNEXPECTED-FAIL | devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js | The default host type should've been set on the panel window (1). - Got undefined, expected right
15:05:12     INFO -  Stack trace:
15:05:12     INFO -  chrome://mochikit/content/browser-test.js:test_is:1285
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:testHost:109
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:testHosts:42
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:test/<:21
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:test:19
15:05:12     INFO -  chrome://mochikit/content/browser-test.js:Tester_execTest:1114
15:05:12     INFO -  chrome://mochikit/content/browser-test.js:nextTest/<:976
15:05:12     INFO -  chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
15:05:12     INFO -  Not taking screenshot here: see the one that was previously logged
15:05:12    ERROR -  225 INFO TEST-UNEXPECTED-FAIL | devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js | The default host type should've been set on the panel window (2). - Got undefined, expected right
15:05:12     INFO -  Stack trace:
15:05:12     INFO -  chrome://mochikit/content/browser-test.js:test_is:1285
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:testHost:111
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:testHosts:42
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:test/<:21
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:test:19
15:05:12     INFO -  chrome://mochikit/content/browser-test.js:Tester_execTest:1114
15:05:12     INFO -  chrome://mochikit/content/browser-test.js:nextTest/<:976
15:05:12     INFO -  chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
15:05:12     INFO -  Not taking screenshot here: see the one that was previously logged
15:05:12    ERROR -  226 INFO TEST-UNEXPECTED-FAIL | devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js | The default host type is present as an attribute on the panel's body. - Got horizontal, expected vertical
15:05:12     INFO -  Stack trace:
15:05:12     INFO -  chrome://mochikit/content/browser-test.js:test_is:1285
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:testHost:114
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:testHosts:42
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:test/<:21
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:test:19
15:05:12     INFO -  chrome://mochikit/content/browser-test.js:Tester_execTest:1114
15:05:12     INFO -  chrome://mochikit/content/browser-test.js:nextTest/<:976
15:05:12     INFO -  chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
15:05:12     INFO -  Not taking screenshot here: see the one that was previously logged
15:05:12    ERROR -  227 INFO TEST-UNEXPECTED-FAIL | devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js | The workers and sources pane's parent is correct for the vertical layout. - Got debugger-widgets, expected vertical-layout-panes-container
15:05:12     INFO -  Stack trace:
15:05:12     INFO -  chrome://mochikit/content/browser-test.js:test_is:1285
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:testHost:123
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:testHosts:42
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:test/<:21
15:05:12     INFO -  chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js:test:19
15:05:12     INFO -  chrome://mochikit/content/browser-test.js:Tester_execTest:1114
15:05:12     INFO -  chrome://mochikit/content/browser-test.js:nextTest/<:976
15:05:12     INFO -  chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
15:05:12     INFO -  Not taking screenshot here: see the one that was previously logged
15:05:12    ERROR -  228 INFO TEST-UNEXPECTED-FAIL | devtools/client/debugger/test/mochitest/browser_dbg_host-layout.js | The instruments pane's parent is correct for the vertical layout. - Got editor-and-instruments-pane, expected vertical-layout-panes-container
15:05:12     INFO -  Stack trace:

Push:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=120a4d4dced81e390d3d25dba18004ad8a0a544d&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-classifiedState=unclassified

Backout:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5a6ef0a517fa09802f7fd92df34488b3cd51f760
Flags: needinfo?(pbrosset)

Comment 6

Last year
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ee8699581c16
Clear the devtools.toolbox.host value if this value is unexpected. r=gl
Flags: needinfo?(pbrosset)
Assignee: nobody → mantaroh
Status: NEW → ASSIGNED
Priority: -- → P3
Duplicate of this bug: 1467821

Comment 8

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/ee8699581c16
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.