Closed Bug 1467693 Opened 3 years ago Closed 3 years ago
Base::Switch Text Direction() and Editor Base::Switch Text Direction To()
59 bytes, text/x-review-board-request
There are two similar methods, but they are created with copy & paste. So, the common code should be merged into new method, SetTextDirection(). Additionally, EditorBase::SwitchTextDirection() is a scriptable method but nobody uses this from JS. So, we can make it from nsIEditor and this patch renames it to ToggleTextDirection() since current name is too similar to SwitchTextDirectionTo().
Comment on attachment 8984371 [details] Bug 1467693 - Merge EditorBase::SwitchTextDirection() and EditorBase::SwitchTextDirectionTo() https://reviewboard.mozilla.org/r/250190/#review256816
Attachment #8984371 - Flags: review?(m_kato) → review+
Pushed by email@example.com: https://hg.mozilla.org/integration/autoland/rev/7fb30739a8a0 Merge EditorBase::SwitchTextDirection() and EditorBase::SwitchTextDirectionTo() r=m_kato
You need to log in before you can comment on or make changes to this bug.