Developer Tools in Nightly won't open

RESOLVED DUPLICATE of bug 1467679

Status

defect
--
critical
RESOLVED DUPLICATE of bug 1467679
Last year
Last year

People

(Reporter: william, Unassigned)

Tracking

({nightly-community, regression, regressionwindow-wanted})

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 unaffected, firefox62 fixed)

Details

Reporter

Description

Last year
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180608100105

Steps to reproduce:

On Ubuntu 17.10 Artful running Nightly 62.0a1 (2018-06-08) (64-bit)

1. Go to any website, for instance https://developer.mozilla.org/en-US/
2a. Hit F12 to open developer tools
2b. Hit Ctrl + Shift + I to open developer tools
2c. Open menu (the "hamburger" one), go to Web Developer, and click any tool to open developer tools



Actual results:

Nothing happens apart from when clicking Responsive Design Mode which enters the mode, but does not open the actual developer tools like Inspector or Debugger.


Expected results:

Developer Tools should open
Reporter

Comment 1

Last year
I'll try to set up
Keywords: regression
Reporter

Comment 2

Last year
(In reply to william from comment #1)
> I'll try to set up

Sorry, premature submit there. I'll try to set up mozregression to pinpoint further, but I use Nightly as my daily driver for web development and I didn't have this issue yesterday.
I can confirm the issue on my mac but not on my linux machine and neither in a Windows VM.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: Untriaged → Developer Tools
Ever confirmed: true
On my mac, the browser console logs this error when I try to open the developer tools:
Error: Unknown hostType: side toolbox-host-manager.js:147:13
Reporter

Comment 5

Last year
(In reply to Pascal Chevrel:pascalc from comment #4)
> On my mac, the browser console logs this error when I try to open the
> developer tools:
> Error: Unknown hostType: side toolbox-host-manager.js:147:13

That's the error I'm seeing as well in the browser console. I'm running Linux in a VirtualBox VM for what it's worth.

Comment 6

Last year
Can reproduce on MacOS with the 62.0a1 (2018-06-07 and 018-06-08).
There a demo of what I tried: https://i.imgur.com/qzhUto4.gif
There's a patch up for that in bug 1467679.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1467679

Comment 8

Last year
Great, the workaround works for me

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.