Various font differences between the First Run page and "about:welcome"

VERIFIED FIXED in Firefox 62

Status

()

defect
P1
normal
VERIFIED FIXED
a year ago
11 months ago

People

(Reporter: cmuresan, Assigned: ewright)

Tracking

Trunk
Firefox 62
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox60 unaffected, firefox61 unaffected, firefox62 verified)

Details

Attachments

(2 attachments)

[Affected versions]:
- Nightly 62.0a1 Build ID 20180607220114

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Steps to reproduce]:
1. Open the Browser and navigate to the about:welcome page.
2. Compare the text fonts from the page with the ones from the First Run page (https://www.mozilla.org/en-US/firefox/60.0.2/firstrun/).

[Expected results]:
- No font differences can be observed.

[Actual results]:
- Almost all text is styled differently.

[Notes]:
- Attached a screenshot of the issue.
Assignee

Comment 1

11 months ago
The currently used font in the moz.org firstrun experience is fira sans. We don't want to fetch a web font from this in-product experience, so we would need to bring the font in-product. I believe there were some concerns with this - one of the reasons was for localization, that this font wouldn't have enough characters. I will however try to fix some small visual differences with the font on about:welcome not appearing bold enough.

Comment 3

11 months ago
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/20fefec583c03c296762308fbf5969b4f24dab94
Bug 1467813 - Make fonts bolder.

https://github.com/mozilla/activity-stream/commit/a17bd5b04d9cc445ecd093f19f1135d7c82b9c75
Merge pull request #4203 from ericawright/font

Fix Bug 1467813 - Various font differences between the First Run page and about:welcome

Updated

11 months ago
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Assignee

Comment 4

11 months ago
perhaps we should re-open this for discussion about the actual font family difference...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 5

11 months ago
Followups should be separate bugs
Assignee: nobody → ewright
Blocks: 1469938
Status: REOPENED → RESOLVED
Iteration: --- → 62.4 - Jul 2
Last Resolved: 11 months ago11 months ago
Priority: -- → P1
Resolution: --- → FIXED
I have verified that the issue is no longer reproducible on the latest Nightly (Build ID 20180625100047) on Windows 10 x64, Mac 10.13.4 and Arch Linux x64. Some strings have been bold in order to resemble the version from release.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.