The devtools toolbox is wrongly moved to the left side of the browser's window when selecting "Dock to right" option

RESOLVED DUPLICATE of bug 1467679

Status

defect
RESOLVED DUPLICATE of bug 1467679
Last year
Last year

People

(Reporter: carmenf, Unassigned)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox60 unaffected, firefox61 unaffected, firefox62 affected)

Details

Attachments

(1 attachment)

Posted image dock to right.gif
[Affected versions]:
- Firefox 62.0a1

[Affected platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- Have a new clean Firefox profile.

[Steps to reproduce]:
1. Start the Firefox browser with the profile from prerequisites.
2. Press the "F12" key.
3. Click the 3 dots button from the right side of the web console.
4. Click the "Dock to right" option from the drop down list.
5. Observe what happens with the Web console.

[Expected result]:
- The Web console is moved to the right side of the browser window.

[Actual result]:
- The Web console is moved to the left side of the browser window.

[Regression range]:
- Last good revision: 9e717c6aaa70daa363832215d3a78ffa605f92bb
- First bad revision: 5bbe892524aaa83997768c9dc9cb7a237e314a88

- Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9e717c6aaa70daa363832215d3a78ffa605f92bb&tochange=5bbe892524aaa83997768c9dc9cb7a237e314a88

Looks like bug 1192642 introduced this behavior.

[Notes]:
- Attached is a screen recording of the issue.
Blocks: 1192642
Summary: The Web console is wrongly moved to the left side of the browser's window when selecting "Dock to right" option → The devtools toolbox is wrongly moved to the left side of the browser's window when selecting "Dock to right" option
This is fixed in Bug 1467679
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1467679
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.