In <are008.html> JavaScript Testcase: 'document.links[n].search' (= link.search) should return something...

RESOLVED DUPLICATE of bug 12559

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 12559
16 years ago
15 years ago

People

(Reporter: John McCann, Assigned: Prashant Desale)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052306

http://mozilla.org/quality/ngdriver/suites/javascript/are008.html
test fails all the results are null

Also stuffed up in RC2

Reproducible: Always
Steps to Reproduce:
1.go to http://mozilla.org/quality/ngdriver/suites/javascript/are008.html
2.look at screen
3.

Actual Results:  Fails

Expected Results:  Passe
(Assignee)

Comment 1

16 years ago
Changing summary. 

Attaching simple testcase to prove that search property of Objects "Link" or 
"Area" is not returning anything.

Confirming bug.
Testcase attachment to follow.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Test fails on client side java script are008 → link.search is not returning anything.
(Assignee)

Comment 2

16 years ago
Created attachment 84927 [details]
Simple Testcase.

BUILDS: 2002-05-23-08-trunk.

STEPS TO REPRODUCE:
1] Load testcase.
2] Click button "Show me First Link.search" [You will get alert]
3] Click "OK" on alert.
4] Click button "Show me Second Link.search" [You will get alert]
5] Click "OK" on alert.

EXPECTED RESULTS:
First alert should show "Link.search = 15"
Second alert should show "Link.search = 12"

ACTUAL RESULTS:
First alert shows "Link.search = "
Second alert shows "Link.search = "
(Assignee)

Comment 3

16 years ago
Correcting expected results.

EXPECTED RESULTS:
First alert should show "Link.search = ?ser=15"
Second alert should show "Link.search = ?ser=12"
The URL's in this testcase are invalid, the search part of the URL's (?xxx) is
part of the hash part of the URL (#xxx), .search does work if you use it on
URL's that don't have a # in them, as per the specs. 4x and IE are broken wrt
this. Over to desale to fix the testcases...
Assignee: jst → desale
(Assignee)

Comment 5

16 years ago
hm.... Good to know this.
I'll fix the testcase accordingly.

Updated

16 years ago
QA Contact: desale → stummala
Component: DOM Content Models → DOM Other

Updated

15 years ago
Blocks: 142649
Blocks: 12559
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4a) Gecko/20030401]

Bug still there.

In the meantime, who can do the following to be more precise ?


In <http://mozilla.org/quality/ngdriver/suites/javascript/are008.html> source,
replace "Bug# 12559" by "Bug# 146788" (3 times).
Summary: link.search is not returning anything. → In <are008.html> JavaScript Testcase: 'document.links[n].search' (= link.search) should return something...
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4a) Gecko/20030401]

(I also see bug 203158 when testing the current bug.)
"Disregard" comment 7:

It's true, but it applies to all bugs, not this one only :-<
could be fixed by this patch:
Index: mozilla-org/html/quality/ngdriver/suites/javascript/are008.html
===================================================================
RCS file: /cvsroot/mozilla-org/html/quality/ngdriver/suites/javascript/are008.html,v
retrieving revision 1.1
diff -u -r1.1 are008.html
--- mozilla-org/html/quality/ngdriver/suites/javascript/are008.html	3 Mar 2000
19:00:01 -0000	1.1
+++ mozilla-org/html/quality/ngdriver/suites/javascript/are008.html	25 Apr 2003
15:51:19 -0000
@@ -46,9 +46,9 @@
 <FORM NAME="workform">
 <A HREF="http://www.netscape.com/index.html#angels0?ser=20" TARGET="_new">
 <MAP NAME="star">
-<AREA NAME="topstar" SHAPE="RECT" COORDS="0,0,300,100"
HREF="http://www.yahoo.com#angels?ser=15" TARGET="_new">
-<AREA NAME="middlestar" SHAPE="RECT" COORDS="0,100,300,200"
HREF="http://www.oracle.com#angels1?ser=12" TARGET="_new">
-<AREA NAME="bottomstar" SHAPE="RECT" COORDS="0,200,300,300"
HREF="http://www.intel.com#angels2?ser=14" TARGET="_new">
+<AREA NAME="topstar" SHAPE="RECT" COORDS="0,0,300,100"
HREF="http://www.yahoo.com?ser=15#angels" TARGET="_new">
+<AREA NAME="middlestar" SHAPE="RECT" COORDS="0,100,300,200"
HREF="http://www.oracle.com?ser=12#angels1" TARGET="_new">
+<AREA NAME="bottomstar" SHAPE="RECT" COORDS="0,200,300,300"
HREF="http://www.intel.com?ser=14#angels2" TARGET="_new">
 </MAP>
 <IMG NAME="testimage" SRC="../res/highstar.gif" ALIGN="left" VSPACE="10"
HEIGHT="300" WIDTH="300" BORDER="0" USEMAP="#star">
 </A>
Changing Hardware/OS from PC/Windows_98 to All/All,
according to "blocks" (in a "part of" relation) bug 12559.
OS: Windows 98 → All
Hardware: PC → All
This is really a duplicate of bug 12559.

*** This bug has been marked as a duplicate of 12559 ***
No longer blocks: 12559
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Removing 'blocks':
*bug 12559: duplicate relation
*bug 142649: see directly bug 12559
No longer blocks: 12559, 142649
You need to log in before you can comment on or make changes to this bug.