Closed Bug 1468008 Opened Last year Closed Last year

Blank spaces besides playback controls on youtube should send clicks to the adjacent control-button

Categories

(Core :: Layout: Form Controls, defect)

60 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1089326
Tracking Status
firefox60 --- affected
firefox61 --- affected
firefox62 --- affected

People

(Reporter: smchase, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180605171542

Steps to reproduce:

Open any video on YT.


Actual results:

There were blank spaces on both sides of the playback controls, in full screen too.


Expected results:

There shouldn't have been blank spaces there.
Correction: the blank spaces should be there, but you should be able to click on them, like in Chrome, but you can't.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0 (20180611220254)

I've tested this report on Windows 10 x64 using latest Nightly, Beta 61.0b13, and Firefox release. When playing a video in YouTube and then I press the blank space on right side of the fullscreen control it is like pressing the play/pause button. The same action in Chrome is switching to fullscreen mode. Like the button in Chrome has a bigger area of action compared to Firefox. It would be great to see the same behavior as in the competitor browser.
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Form Controls
Ever confirmed: true
Product: Firefox → Core
Thanks for the bug report.

Under the hood, that area is covered by some content that is overflowing from a <button>.  So this is a version of bug 1431804, which is a duplicate of bug 1089326.  Marking this as a duplicate of that general issue as well.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1089326
this sounds like a layout issue no?
bug 1089326 is about hit testing and such.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
The title & comment 0 here is a bit misleading -- this bug is purely about hit-testing.  See comment 1 for reporter's clarification.

The blank spaces exist in both Firefox and Chrome, but they're treated as part of the adjacent button (the button they're overflowing from) in Chrome, but they're not in Firefox.
Summary: Blank spaces besides playback controls on youtube → Blank spaces besides playback controls on youtube should send clicks to the adjacent control-button
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → DUPLICATE
Duplicate of bug: 1089326
Here's a screenshot showing the DOM around the button & this blank space, in devtools.

The abspos "::before"-generated child here is what covers up the blank space in question. And it is positioned outside of the button ("left: -12px"), which is why bug 1089326 is involved here.
Why? bug 1089326 is about hit testing and such. Nothing to do with layout
So is this bug. The hits on the ::before element should be sent to the button.

Per comment 3, this bug here is precisely an instance of bug 1431804 "Buttons don't receive clicks on overflowing pieces of descendants", which you marked as a dupe of bug 1089326.
aha, ok, sorry, somehow misinterpreted "blank spaces" being the issue here.
You need to log in before you can comment on or make changes to this bug.