Closed Bug 1468316 Opened 2 years ago Closed 2 years ago

Extra area in Privacy Panel when visiting the Tracking Protection tour and TP is toggled on and off

Categories

(Firefox :: Site Identity, defect, P5)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 --- affected
firefox63 --- affected

People

(Reporter: bogdan_maris, Unassigned)

References

(Blocks 1 open bug)

Details

[Affected versions]:
- Nightly 62.0a1

[Affected platforms]:
- macOS 10.13.5
- Ubuntu 18.04
- Windows 10 64bit

[Steps to reproduce]:
1. Open Firefox
2. Visit the following URL: https://www.mozilla.org/en-US/firefox/62.0a1/tracking-protection/start/?step=1
3. Follow the steps until reaching step 3 of 3 
4. Click > icon (Show connection details)
5. Turn off Tracking Protection from Hamburger Menu
6. Click < icon to go back to Privacy Panel

[Expected result]:
- Privacy Panel has no visual defects.

[Actual result]:
- Extra area is shown under Clear Cookies and Site Data...

[Regression range]:
- Not a regression since its also reproducible on the build where this was introduced, Nightly 2018-06-01

[Additional notes]:
- Here is a screencast showing the issue: https://drive.google.com/open?id=1lhu72OO2j4LkFImKM63_-gUgQA1-c8uh (the screencast was made on ubuntu, .mp4 file and it would not work if I would have added it to bugzilla directly).
This should have gotten fixed by bug 1462470 (because we're now always showing the tracking protection section). Would you like to verify and close this?
Depends on: 1462470
Flags: needinfo?(bogdan.maris)
Priority: -- → P3
Issue still reproduces after bug 1462470, but a little different: https://drive.google.com/open?id=1hVXN8-udeCXqy8XqjIVhgrJexPfm4jWE
Flags: needinfo?(bogdan.maris) → needinfo?(jhofmann)
Yeah, there's a general problem with popup resizing but it's probably fine to track this individually.
Flags: needinfo?(jhofmann)
I just realized you have to be in the TP tour for this to happen (because you can't have both popups open at the same time normally), so this is rather a P5.
Priority: P3 → P5
This issue is no longer reproducible on Fx 62.0b17. I verified using Windows 10 x64, mac OS 10.12.6 and Ubuntu 16.04 LTS. Marking the bug accordingly.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.