Closed Bug 146835 Opened 23 years ago Closed 13 years ago

status loading when showing javascript alert message

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows XP
defect
Not set
trivial

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: etreise, Unassigned)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

On this page if i click on a blue "i" icon (you can find them behind some links)
a message window pops up. when i move the mouse cursor inside this window,
mozilla changes his state to "Loading...".

Reproducible: Always
Steps to Reproduce:
1. click on a blue "i" icon
2. move mouse cursor inside the poped up window
3.

Actual Results:  mozilla reports "Loading..."

Expected Results:  mozilla's state should not change
Confirming reported behavior with Mozilla trunk binary 20020617xx.

I found an "i" icon 75% of the way down the page, to the right
of a link called "Fraps 1.8"


<a href="/downloads/fraps.php">Fraps 1.8</a>

<a href="javascript:popupMsg('Customisable hotkeys for screen captures and 
framerate logging. \nFixed a bug and now the counter displays in more games.')">

<img alt="Info" src="http://www.3d-center.de/images/i.gif" width="15"            
height="15" border="0">

</a>


where we have:

function popupMsg(msg)
{
    alert(msg);
}



After the initial load of the webpage, the status bar in Mozilla says

      "Starting Plug-in for type application/x-shockwave-flash"

When I mouseover the "i" link, it changes to 

      "javascript:popupMsg('Customisable     etc. )"

After the alert comes up, if I move my cursor over the modal alert,
the status bar in the Mozilla window changes back to 

      "Starting Plug-in for type application/x-shockwave-flash"


In IE6, the status bar changes to this on mousing over the "i" link:

      "javascript:popupMsg('Customisable     etc. )"

and remains set to this until you dismiss the alert. Mousing over the
alert while it is up does not cause any window.status change.


This is not a JS Engine issue. Reassigning to DOM Level 0 and to
danm, who will know what the proper behavior should be here -
Assignee: rogerl → danm
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → DOM Level 0
Ever confirmed: true
QA Contact: pschwartau → desale
When I move my cursor over the modal alert, the Mozilla icon in the right upper
corner of the browser changes and the Stop button is enabled, as if a page is
loaded.
To see more, open 2 tabs in the browser and move mouse over the alert dialog,
the status shown in the tab above changes to "Loading...".
Assignee: danm.moz → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: desale → general
Eugen: Is this still a problem ?
Cannot reproduce this problem. The icons, which caused the problem, are not used for some years.
Thanks Eugen for your response after 10 years !
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.