Closed Bug 1468355 Opened 2 years ago Closed 4 months ago

"Clear Cookies and Site Data" menu item in the control centre/site information shows up with a noticeable delay

Categories

(Firefox :: Site Identity, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox65 --- wontfix
firefox66 --- wontfix
firefox70 --- verified
firefox71 --- verified

People

(Reporter: ehsan, Assigned: johannh)

References

(Regressed 1 open bug)

Details

Attachments

(2 files)

Attached video Screencast
See the screencast.  It seems that we add this item to the control centre dynamically, which results in a jarring user experience when opening the menu.
Yup, I agree and I hate it. :) This is hopefully going to be fixed with bug 1460768 which I'm planning to get done in 62. We could dupe it but it might make sense to keep this bug around since the other bug is rather focused on the site data manager in about:preferences.
Component: Address Bar → Site Identity and Permission Panels
Depends on: 1460768
Priority: -- → P2
Duplicate of this bug: 1472872
I still see this issue in 66 Nightly. The "Clear Cookies and Site Data" menu item takes 5 seconds to show up in my default profile. In a new profile, the menu item only takes about 1 second, so the delay seems to be correlated with the number of cookies.
Summary: Clear Cookies and Site Data item in the control centre shows up with a noticeable delay → "Clear Cookies and Site Data" menu item in the control centre/site information shows up with a noticeable delay
See Also: → 1564077

This is hopefully going to be fixed with bug 1460768 which I'm planning to get done in 62

It's still not fixed in Nightly 70. Could the problem be prioritized, please? Firefox is a fast browser but this problem destroys a bit of the hard work you all invest to improve the perceived performance of Firefox. :-) And I guess with Skyline there will be a another marketing push for the address bar panels so users will probably notice the problem even more. People really shouldn't wait multiple seconds (!) to see the full content of the panel. ;-)

Flags: needinfo?(jhofmann)

Well, that's quite a dramatic way of framing it but I agree we should fix this in 70...

Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Flags: needinfo?(jhofmann)

The idea here is that we avoid updating all site data in SiteDataManager.jsm
just for checking a single host/origin and that we optimize performance by prioritizing
the most common data type (cookies) and synchronous lookups (AppCache) and returning
early if any data was found.

We will still refresh the site data list for clearing once the user clicks on "Clear Site Data".

No longer depends on: 1460768
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1d7d0461c582
Optimize checking for site data usage for the site identity panel. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Regressions: 1577417

(In reply to Johann Hofmann [:johannh] from comment #5)

Well, that's quite a dramatic way of framing it but I agree we should fix this in 70...

Sorry, it was not my intention to be dramatic. All I wanted to say was that sometimes it only needs one UI element with a weak performance to get the impression that the whole product is slow even if it's not true at all. Thank you so much for fixing this performance problem. I can verify it's fixed now. :)

Regressions: 1577397
Regressions: 1577395
Flags: qe-verify+

Managed to reproduce the issue on Firefox 62.0a1 (2018-06-12), under Ubuntu 16.04x64.
The issue is no longer reproducible on Firefox 71.0a1 (2019-09-26), or on Firefox 70.0b9.
Tests were performed under Ubuntu 16.0x64, Windows 10x64 and macOS 10.12.6.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

On Firefox 70.0.1 (Windows 10 x64), the button is there as soon as I click the lock, but clicking it seems to do nothing, until 2-4 seconds later a dialog appears.

If I click the button multiple times, 2-4 seconds later, multiple dialog appear simultaneously.

If I close the dialog and press the button again (on the same tab with the same site open), I get a 2-second delay again.

Name: Firefox
Version: 70.0.1
Build ID: 20191030021342
Update Channel: release
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

(In reply to jimbo1qaz from comment #11)

On Firefox 70.0.1 (Windows 10 x64), the button is there as soon as I click the lock, but clicking it seems to do nothing, until 2-4 seconds later a dialog appears.

If I click the button multiple times, 2-4 seconds later, multiple dialog appear simultaneously.

If I close the dialog and press the button again (on the same tab with the same site open), I get a 2-second delay again.

Name: Firefox
Version: 70.0.1
Build ID: 20191030021342
Update Channel: release
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Sorry for the delay, I was out, can you please file a new bug for this?

Flags: needinfo?(jimbo1qaz)
Flags: needinfo?(jimbo1qaz)
You need to log in before you can comment on or make changes to this bug.