If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Windows task bar stays hidden when using full screen mode and a virtual screen manager

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
minor
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: john napiorkowski, Assigned: Samir Gehani)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052306

I have a virtual screen manager, set up for three virtual windows.  I can switch
between the virtual windows by either 1) alt-tabbing to an application that is
displayed in a particular window, or 2) bumping my mouse on the right or left
side of the screen will switch me to the virtual screen on that side.

When using full screen mode and trying to switch to one of the two other screens
using the 'bump mouse on screen edge' method, the windows task bar stays hidden
until I give the focus to a window on the new screen or to the desktop.

Reproducible: Always
Steps to Reproduce:
1.  Get a virtual windows manager, which can switch screens without taking the
focus off the current window or desktop.
2.  Put Mozilla into full screen mode.
3.  Switch windows.

Actual Results:  Switched screens and noticed that the windows task bar is
missing until take the focus away from a full screen mozilla.  There is a blank
strip where I would expect to see the task bar.

Expected Results:  restore the task bar when leaving the virtual window that has
a full screen mozilla in it, even when the mozilla window keeps the focus.

This problem does not occur when using any version of Internet Explorer that has
a full screen mode.

I think the problem is that the full screen mode restores the task bar only when
the browser window loses focus, not just when the mouse somehow leaves the
window, as it does with a virtual screen manager with that feature.  I wonder if
people with multiple monitors have a similar problem?

Comment 1

15 years ago
reporter (john): can you reproduce this bug with a recent build of mozilla (for
example, 1.2)? if so, please comment again with details. if not, please resolve
this bug as WORKSFORME. thanks.

Comment 2

15 years ago
no response from reporter for >30 days. resolving WORKSFORME.

reporter: if you can reproduce this with a recent build of mozilla, please
reopen this bug and give details. thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.