Closed Bug 1468440 Opened 2 years ago Closed 2 years ago

Update close and mute/unmute buttons tooltip for multi-selected tabs.

Categories

(Firefox :: Tabbed Browser, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox62 --- wontfix
firefox63 --- verified

People

(Reporter: ablayelyfondou, Assigned: jaws, Mentored)

References

(Blocks 1 open bug)

Details

(Whiteboard: [blocking-multiselect-tabs])

Attachments

(1 file)

When mouse is over the close button of a multi-selected tab, show "Close Selected Tabs" instead of "Close Tab"
Summary: Update close button tooltip for multi-selected tabs. → Update close and mute/unmute buttons tooltip for multi-selected tabs.
In addition to close button tooltip, mute/unmute button tooltip should be updated to show "mute/unmute/play tabs" in a multiselect context.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [blocking-multiselect-tabs]
If this affects the [X] icon on each tab, and the `c< ))` (bad representation of the mute icon) icon on every tab, not sure it makes much sense... Since those icons are tab-specific.

It would make more sense to change the context menu items though.
(In reply to Tim Nguyen :ntim from comment #3)
> If this affects the [X] icon on each tab, and the `c< ))` (bad
> representation of the mute icon) icon on every tab, not sure it makes much
> sense... Since those icons are tab-specific.
> 
> It would make more sense to change the context menu items though.

Not when there is a multiselection present. Clicking those icons will affect all tabs that are in the selection, as long as the targeted tab is within the selection as well.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Comment on attachment 9004374 [details]
Bug 1468440 - Update close, unblock audio and mute/unmute button tooltips for multi-selected tabs. r?mconley

Mike Conley (:mconley) (:⚙️) has approved the revision.
Attachment #9004374 - Flags: review+
Priority: P3 → P1
Comment on attachment 9004374 [details]
Bug 1468440 - Update close, unblock audio and mute/unmute button tooltips for multi-selected tabs. r?mconley

Francesco Lodolo [:flod] has approved the revision.
Attachment #9004374 - Flags: review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c21566b512f1
Update close, unblock audio and mute/unmute button tooltips for multi-selected tabs. r=mconley,flod
https://hg.mozilla.org/mozilla-central/rev/c21566b512f1
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Reproduced the issue with 63.0a1(2018-07-17) on Win10x64.
Verified with 63.0b7 and 64.0a1 (2018-09-20) on Win10x64, MacOS10.13.6, Ubuntu16.04 and can confirm that the tooltip messages are properly displayed.

During testing, I've noticed that there is a scenario that may have been overlooked; logged it as bug 1492900.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Depends on: 1492900
You need to log in before you can comment on or make changes to this bug.