Closed Bug 1468453 Opened 2 years ago Closed 2 years ago

Warning notifications inside Download panel are not visible in Dark theme

Categories

(Firefox :: Theme, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- wontfix
firefox62 --- fixed

People

(Reporter: Anca, Assigned: ntim)

References

Details

(Keywords: regression, Whiteboard: [ntim-intern-project])

Attachments

(5 files)

Attached image screenshot issue.png
[Affected versions]: 
- 61.0b13 (20180611134439)
- 62.0a1 (2018-06-12)

[Affected platforms]:
- Windows 10 x64
- macOS 10.13

[Steps to reproduce]:
1. Enable the dark them from Menu-Customize-Themes
2. Go to http://testsafebrowsing.appspot.com/ 
3. Click on the first link from Desktop Download Warnings section
4. Open the Download panel

[Expected result]:
- The warning message is visible. 

[Actual result]:
- The warning message is barely visible.

[Additional Notes]:
- When is selected, the text has no visibility problems. 
- On Ubuntu, the warning message is clear and discernible, but is not colored in red.
Yikes. Can you please take a look, Tim?
Flags: needinfo?(ntim.bugs)
Assignee: nobody → ntim.bugs
Flags: needinfo?(ntim.bugs)
Blocks: 1408121
I'm building the RC of 61 today, but I'd take this in a respin if the opportunity presents itself.
Flags: qe-verify+
Comment on attachment 8985984 [details]
Bug 1468453 - Fix text color of malware downloads on dark themes.

https://reviewboard.mozilla.org/r/251470/#review257746
Attachment #8985984 - Flags: review?(jaws) → review+
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/caa65f3920d6
Fix text color of malware downloads on dark themes. r=jaws
https://hg.mozilla.org/integration/autoland/rev/0ccf890eda26
Fix macOS font-smoothing on arrow panels. r=jaws
https://hg.mozilla.org/mozilla-central/rev/caa65f3920d6
https://hg.mozilla.org/mozilla-central/rev/0ccf890eda26
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Attached image nightly win10 x64.PNG
Hi!

I've checked the above issue on Win10 x64 on an older version of Nightly Build ID: 20180530100110 and compared with the latest version Build ID:20180621013659. There is indeed an improvement compared to the older version (brighter red color for the warning text) but still in my opinion the text is hardly readable and it depends very much on ones display properties (see picture attached "nightly win10 x64.PNG"). Can't we improve this a little bit more?

Also tried on macOS 10.13 on the latest Nightly, Build ID: 20180621100048 and the issue seems fixed there. (see "latest nightly mac 13.png")

On Ubuntu 18.04 tried on latest Nightly, Build ID: 20180621013659 but the issue is the same as reported initially "On Ubuntu, the warning message is clear and discernible, but is not colored in red."
Flags: needinfo?(ntim.bugs)
> Can't we improve this a little bit more?
I've used the brightest red on this page: https://design.firefox.com/photon/visuals/color.html#red

The description line uses the same color at 0.7 opacity, one solution could be increasing the opacity, but that's more a design decision. Amy, what do you think ?

> On Ubuntu 18.04 tried on latest Nightly, Build ID: 20180621013659 but the issue is the same as reported initially "On Ubuntu, the warning message is clear and discernible, but is not colored in red."

From the code I was reading, it seems that it was intentional, because we want to use system colors on Linux and Windows high contrast.
Flags: needinfo?(ntim.bugs) → needinfo?(amlee)
Hi, 

The red we have in the photon palette doesn't pass contrast tests in Dark theme. I will mention this to the DSG team. In the meantime, my recommendation is to use the default text colour we have currently for downloads.
Flags: needinfo?(amlee)
Are we planning to reopen this bug for follow-up work or to move that to a new one?
Flags: needinfo?(ntim.bugs)
I can confirm all the mentioned above information from comment 11. I’ve just checked this issue on Firefox  62.0b8 and latest Nightly. For now, I will remove the qa+ flag, but not mark the bug as verified fixed, until a final decision is made regarding future follow-up work for it.
Flags: qe-verify+
(In reply to Ryan VanderMeulen [:RyanVM] from comment #14)
> Are we planning to reopen this bug for follow-up work or to move that to a
> new one?

Filed bug 1491614, thanks Amy!
Flags: needinfo?(ntim.bugs)
See Also: → 1530632

I managed to reproduce the issue following STR from the description on Fx 71.0b4 64-bit and 32-bit version using Windows 10 x64 and also on windows 7. Should we log a new bug for this issue or reopen this one?

Flags: needinfo?(ntim.bugs)

(In reply to Negritas Sergiu from comment #17)

I managed to reproduce the issue following STR from the description on Fx 71.0b4 64-bit and 32-bit version using Windows 10 x64 and also on windows 7. Should we log a new bug for this issue or reopen this one?

https://bugzilla.mozilla.org/show_bug.cgi?id=1491614 is filed for using a different text color already. Could you attach a screenshot of what you're seeing ?

Flags: needinfo?(ntim.bugs)

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
You need to log in before you can comment on or make changes to this bug.