Allow right-click of the about:addon's options page

VERIFIED FIXED in Firefox 66

Status

()

defect
P3
normal
VERIFIED FIXED
Last year
5 months ago

People

(Reporter: u608644, Assigned: rpl)

Tracking

60 Branch
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 wontfix, firefox65 wontfix, firefox66 verified)

Details

Attachments

(7 attachments)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20100101

Steps to reproduce:

1. Install any add-ons which using options_ui. Decentraleyes, HTTPSE and so on
2. Open about:addons and select it, click Options.
3. Right-click options page area.


Actual results:

Right-click is completely disabled; no menu popup.
In Firefox ESR, I can right-click it. Why not in latest Firefox?
At least please allow right-click on textarea and input area. Not having right-click menu(to copy/paste data) is affecting user experience.


Expected results:

Like Firefox ESR does, right-clicking should not be disabled in about:addons.
Duplicate of this bug: 1468668
Posted image right_click.png
Version 	60.0.2
Build ID 	20180605171542	
Update Channel 	release
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0


Version 	62.0a1
Build ID 	20180618100844
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

Hi John W,
Thank you for your contribution to our community.
I installed both "Decentraleyes, HTTPS Everywhere" add-ons in latest Firefox release and Nightly builds and 
Right-click is working as expected on Add-ons Options page. 
I am attaching the screenshot of it.

I would suggest you update your Firefox or install latest Nightly and try it. 
Thank you.
(In reply to Damira Akh from comment #3)
> I would suggest you update your Firefox or install latest Nightly and try
> it. 
> Thank you.

I have Firefox 61.0 (stable) but I still can't right-click Decentraleyes' <INPUT> element. (Decentraleyes > Exclude domain's <input> box)
Aha, I understand what you mean...
I'm not talking about "right-click empty area"(like your screenshot).

Incorrect:
3. Right-click options page area.

Correct:
3. Right-click options page area's <INPUT type=text|password>, <TEXTAREA>.
Flags: needinfo?(dakhmedova)
Flags: needinfo?(dakhmedova)
Hi,

I go back and tested input field area working as expected.
I am attaching the screenshot.

Build ID 	20180621125625
Update Channel 	release
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
(In reply to Damira Akh from comment #7)
> Hi,
> 
> I go back and tested input field area working as expected.
> I am attaching the screenshot.
> 
> Build ID 	20180621125625
> Update Channel 	release
> User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101
> Firefox/61.0

No offense, but come on. Your screenshot is Firefox's UI, not add-on's.

> (Decentraleyes > Exclude domain's <input> box)

options_ui's webpage (inside of about:addon).

Can anyone confirm this already? I can reproduce with 10+ PCs.
Flags: needinfo?(dakhmedova)
And Firefox 52 ESR doesn't have this bug. (repeating)
Hi John,
Please, can u provide a screenshot?
Flags: needinfo?(dakhmedova)
Build ID 	20180605171542
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

If I understood this bug correctly I was able to reproduce this issue.
I am attaching the screencast.

John,
If you mean different issue please, can you take a screencast of your steps?
Posted file 123.swf
Component: Untriaged → General
Component: General → Add-ons Manager
Product: Firefox → Toolkit
Flags: needinfo?(lgreco)
Priority: -- → P3
Comment on attachment 9020364 [details]
Bug 1468460 - Support context menu in WebExtensions options pages embedded inside an about:addons tab.

This is clearly an issue related to the oop extension mode, when the extension options page runs in the main extension process the context menu works as expected without the need to "wire it" explicitly, on the contrary for the extension options page that runs in the child extension process we already had to handle the context menu more explicitly (e.g. for the sidebars and the devtools pages).

The main reason for the needinfo was that I wanted to take a deeper look first and check if we could just reuse for the extensions options_page the same approach that we currently use for the extension sidebar and the devtools panels (based on webext-panels.xul/webext-panels.js, as we already handle the context menu there, as well as other popups that have the same issue).

Unfortunately, it seems that webext-panels.xul is triggering some new "issues" when running inside a browser element embedded into the about:addons page (webext-panels.js raises an error as soon as we append the browser element [1], and the error is originating from the browser XUL widget constructor [2]).

I suspect that the reason for these failures may be related to the fact that about:addons is inside a tabbrowser's XUL browser element, because we didn't have this issue in the sidebar or in the devtools panel, but I've not been yet able to dig enough into it to identify the exact underlying reasons (we may try to ask to Kris, as he may have an idea or some pointers that may help us to get a better picture and see if there is a reasonable way to solve these issues).

In the meantime I thought that it was also worth to try to see "how bad it may look" if we would add the changes needed to handle the OOP context menu directly into extensions.js, and so I put together a draft patch of this alternative approach, for a feedback (and to push it to try [3] and double-check if it would break any of the existing tests).

[1] https://searchfox.org/mozilla-central/rev/d5fc6f3d4746279a7c6fd4f7a98b1bc5d05d6b01/browser/base/content/webext-panels.js#67
[2] https://searchfox.org/mozilla-central/rev/d5fc6f3d4746279a7c6fd4f7a98b1bc5d05d6b01/toolkit/content/widgets/browser.xml#999
[3] https://treeherder.mozilla.org/#/jobs?repo=try&revision=78464e2d08103118be627b18659e465edd3a27ae
Flags: needinfo?(lgreco)
Attachment #9020364 - Flags: feedback?(mixedpuppy)
Attachment #9020364 - Flags: feedback?(mixedpuppy) → feedback+
Attachment #9033006 - Attachment description: Bug 1468460 - Ensure that the extensions options page viewType gets recognized correctly by ext-menu.js. → Bug 1468460 - Fix and test extension menus and menus.overrideContext on options_ui pages.
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/d3f022310ff3
Support context menu in WebExtensions options pages embedded inside an about:addons tab. r=mixedpuppy,robwu
https://hg.mozilla.org/integration/autoland/rev/dd5395e679a6
Fix and test extension menus and menus.overrideContext on options_ui pages. r=mixedpuppy,robwu
Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Assignee: nobody → lgreco
Depends on: 1519121
Posted image verified.png

Verified using FF 66.0a1 (20190116093310) on Windows 10 x64, the issue is no longer reproducing on this version so I can confirm the fix. Also verified that it reproduced using Firefox 65.0b7 and 64.0. I've used the above mentioned Decentraleyes extension for validating.

Status: RESOLVED → VERIFIED
See Also: → 1428943
You need to log in before you can comment on or make changes to this bug.