Closed Bug 1468495 Opened Last year Closed Last year

The 3-pane inspector widths are not properly adjusted when first used

Categories

(DevTools :: Inspector, defect, P3)

defect

Tracking

(firefox-esr52 unaffected, firefox-esr60 wontfix, firefox60 wontfix, firefox61 wontfix, firefox62 verified, firefox64 verified, firefox65 verified, firefox66 verified)

VERIFIED FIXED
Firefox 62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- wontfix
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- verified
firefox64 --- verified
firefox65 --- verified
firefox66 --- verified

People

(Reporter: JuliaC, Assigned: gl)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

[Affected versions]:
- 62.0a1 (2018-06-13)
- 61.0b13 build1 (20180611134439) 
- 60.0.2 build1 (20180605171542)

[Affected platforms]:
- Windows 10 x64
- Ubuntu 16.04 x64
- macOS 10.10.5

[Steps to reproduce]:
1. Launch Firefox 
2. Open a random page and launch the Inspector 
3. Go to about:config and make sure that devtools.inspector.three-pane-enabled and devtools.inspector.three-pane-toggle prefs are set to true 
4. Reopen the Inspector on a random page and notice each panel's width 

[Expected result]:
- [step4] The 3-pane inspector widths are properly adjusted

[Actual result]:
- [step4] The HTML Inspector, the CSS rules section and the side section have the same width since the first opening (for more details, see the following screencast https://drive.google.com/file/d/1q5blp25LX1WO4n1E4rsT8Xbd8ccrihTW/view?usp=sharing)

[Regression range]:
- This issue is reproducible all the way back to 59.0a1 (2017-12-08) (when bug 1369945 was fixed)

[Additional notes]:
- The behaviour gets normal after toggling the split view
- On older versions of Firefox (60 and 59), the widths are not calibrated after toggling the split view
- Firefox 62 has the 3-pane inspector enabled by default, but the issue can be reproduced if firstly disabling it
Product: Firefox → DevTools
Assignee: nobody → gl
Status: NEW → ASSIGNED
Priority: -- → P3
Comment on attachment 8985933 [details]
Bug 1468495 - Reset the inspector widths for the first run of 3 pane inspector.

https://reviewboard.mozilla.org/r/251414/#review257918
Attachment #8985933 - Flags: review?(pbrosset) → review+
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/130fd3919bd9
Reset the inspector widths for the first run of 3 pane inspector. r=pbro
https://hg.mozilla.org/mozilla-central/rev/130fd3919bd9
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Flags: qe-verify+
Hi, I can Confirm this issue as Fixed in Nightly 66.0a1 (2018-12-19) Beta 65.0b2 and Release 64.0, I will mark this issue Accordingly.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.