Closed Bug 1468535 Opened Last year Closed Last year

Port raptor-speedometer firefox to linux64

Categories

(Testing :: Raptor, enhancement)

Version 3
enhancement
Not set

Tracking

(firefox62 fixed)

RESOLVED FIXED
mozilla62
Tracking Status
firefox62 --- fixed

People

(Reporter: rwood, Assigned: rwood)

References

Details

Attachments

(1 file)

No description provided.
Try run to see latest status of Raptor tests on all platforms (only OSX is green so far):

https://treeherder.mozilla.org/#/jobs?repo=try&revision=54dde805af6faeac619af64144b0310ce0f8ea75&filter-tier=1&filter-tier=2&filter-tier=3
Depends on: 1469280
Summary: Raptor fixes to run raptor-speedometer firefox on linux64 and win10 → Port raptor-speedometer firefox to linux64
Also add it to mozilla-central tier 3.
Assignee: nobody → rwood
Status: NEW → ASSIGNED
Ah, speedometer on linux failure was a legitimate intermittent failure, one cycle was sometimes taking longer than the page_timeout of 2 min. Increasing the page_timeout fixes this.
Comment on attachment 8987150 [details]
Bug 1468535 - Port raptor-speedometer firefox to linux64;

https://reviewboard.mozilla.org/r/252382/#review258856

::: testing/raptor/raptor/tests/raptor-speedometer.ini:11
(Diff revision 1)
>  
>  [DEFAULT]
>  type =  benchmark
>  test_url = http://localhost:<port>/Speedometer/index.html?raptor
> -page_cycles = 1
> -page_timeout = 120000
> +page_cycles = 5
> +page_timeout = 180000

do you think this is enough?  I guess we can revisit when we see more intermittent timeouts.  Also, it would be nicer to have a better error message to know this is a page_timeout issue- I know it said timeout, but we suspected other things.
Attachment #8987150 - Flags: review?(jmaher) → review+
Comment on attachment 8987150 [details]
Bug 1468535 - Port raptor-speedometer firefox to linux64;

https://reviewboard.mozilla.org/r/252382/#review258856

> do you think this is enough?  I guess we can revisit when we see more intermittent timeouts.  Also, it would be nicer to have a better error message to know this is a page_timeout issue- I know it said timeout, but we suspected other things.

Did a bunch of try runs and it looks fine, this is just the timeout for a single cycle, not all 5 pagecycles. Right now raptor only has the one timeout - if measurements aren't received by the page_cycle timeout then it times out. That could be caused by lots of reasons i.e. webext is broken, etc. but there is actually only one overall timeout. I think the key is to capture other errors (Bug 1470450 - Caputure raptor webext js console errors).
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c2c89b7bb8b5
Port raptor-speedometer firefox to linux64; r=jmaher
Blocks: 1449180
https://hg.mozilla.org/mozilla-central/rev/c2c89b7bb8b5
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
You need to log in before you can comment on or make changes to this bug.