File Bookmarks (CTRL+SHIFT+D) default vertical size is too small

VERIFIED FIXED in mozilla1.4beta


Bookmarks & History
16 years ago
14 years ago


(Reporter: Peter Lairo, Assigned: janv)


Dependency tree / graph
Bug Flags:
blocking1.4a -

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [adt2])


(3 attachments)



16 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0+) Gecko/20020518

File Bookmarks (CTRL+SHIFT+D) default vertical size is too small

Subject says all. 

This bug is a "spinoff" from bug 99860. The following comment from bug 99860
comment #57 prooves that this bug is *not* a duplicate of that bug: "This patch
doesn't fix the size problem of the 'File Bookmark' dialog. That is a separate
issue and should not be handled here."


16 years ago
Blocks: 145941


16 years ago
Keywords: mozilla1.0, ui

Comment 1

16 years ago
did you read  bug 99860 comment #55 ?

Comment 2

16 years ago
Yes I did, but I didn't consider it explicit enough. I just want to keep one
issue per bug; and bug 99860 is trying to do too much. That bug can depend on
this bug.
I have to assume you did not in fact read that comment....
Depends on: 123207
Ever confirmed: true

Comment 4

16 years ago
I did read it, but perhaps I didn't understand it. To me, "I got the height
property" doesn't necessarily have to mean "the default vertical size is now fixed".

Comment 5

16 years ago
*** Bug 146990 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
OS -> all
OS: Windows 98 → All

Comment 7

16 years ago
See also bug 152727 which I just filed. Even worse case of this, but only can
happen once per Mozilla run.
Keywords: mozilla1.0


16 years ago
Keywords: mozilla1.0.1, mozilla1.1, nsbeta1, nsbranch

Comment 8

16 years ago
Nav triage team: nsbeta1-.  Let's address this in the next release.
Keywords: nsbeta1 → nsbeta1-

Comment 9

16 years ago
I don't mean to be disrespectful (and I am no programmer), but doesn't fixing
this involve changing just *one* number in *one* line of code? (i.e., the
default vertical size in pixels)

Also, this bug is particularly nasty because of bug 145941.

Comment 10

16 years ago
I agree with comment #1, this is a separate issue from bug 99860. I was about to
file this myself but Peter for faster.

As to question of simplicity (comment #9): we cannot set explicit height for the
file bookmark window because the window is used in four different modes (modes
are listed in addBookmark.js).

I'll assign this to myself because I will try to fix this. I hope that Ben
doesn't mind.
Assignee: ben → Kalle.Valo

Comment 11

16 years ago
I had a typo in comment #10. I meant to say:

I agree with comment #0, this is a separate issue from bug 99860. I was about to
file this myself but Peter for faster.

Comment 12

16 years ago
Kalle: There is no "addBookmark.js" on my harddrive. Would you be so kind as to
say what the four modes are? (just out of curiosity) Thanks.

Comment 14

16 years ago
Perhaps this may help find the problem.  Under the Modern theme, I find that the
Bookmark -> File Bookmark... dialog comes up with insufficient height *if more
than one tab is active*.  If only one tab is active (and it doesn't matter if
the "Hide the tab bar when only one tab is open" preference is checked or not),
then the dialog can be resized, and the new size will persist.  If two or more
tabs are active, the dialog comes up too short and size changes will not persist.

Comment 15

16 years ago
Ack!  I spoke too soon.  It seems others already observed this phenomenon in bug
123207 comment 7 and bug 123207 comment 19.  What's more, the patch in
attachment 87507 [details] [diff] [review] from bug 123207 comment 21 fixes *this* bug for me.  After a
restart, the bookmark dialog comes up too small the first time, but size changes
persist after that regardless of how many tabs are open, and it works correctly
in the <default> and "New Bookmark" modes.  (I'm not sure how to test the other
two modes.)  There's still the cosmetic issue that the *first* time the dialog
comes up, it seems too small.

Comment 16

16 years ago
One last note...  My last comment applied to the MOZILLA_1_0_BRANCH.  On a June
19 pull of Seakmonkey, the patch only half works.  With two or more tabs open,
the dialog opens with its last size (rather than always opening too small) *but*
changes made to the size do not persist.  Changes made to size with one tab open
*do* persist.

Comment 17

16 years ago
On a June 27 pull of Seamonkey, the problem mentioned in comment 16 is resolved.
 However, I noticed that the patch broke bookmarking a group of tabs.  I'll
submit a fixed patch under bug 123207 that works with group bookmarking, too.

Comment 18

16 years ago
Nominating for buffy; good usability/polish fix.
Keywords: nsbeta1- → nsbeta1

Comment 19

16 years ago
*** Bug 157426 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
Created attachment 93760 [details]
Example with redesigned File Bookmarks dialog

While I was trying to fix bug 99860 I took this screenshot. I was taken with a
new clean profile with default bookmarks. I had applied attachment 93758 [details] which
moves 'Use Default' and 'New Folder' buttons below of bookmarks tree. 

For some reason bookmarks tree just shows it's heading row but not the content
itself. After window is resized, tree's content is shown without problems. 

Because of bug 123207 this is a huge usability problem for people who are using
tabbed windows. They (myself included) have to resize File Bookmarks window
every time it's opened.


16 years ago
Keywords: mozilla1.1 → mozilla1.2

Comment 21

16 years ago
*** Bug 169234 has been marked as a duplicate of this bug. ***

Comment 22

16 years ago
*** Bug 171573 has been marked as a duplicate of this bug. ***

Comment 23

16 years ago
*** Bug 174267 has been marked as a duplicate of this bug. ***

Comment 24

16 years ago
Can't reproduce this anymore with 1.2b on Windows 2000. Now the dialog remembers
its size.

Comment 25

16 years ago
Seems to. The default size still needs to be increased, certainly.

Comment 26

16 years ago
Re comment #24:
That was bug 123207.
This bug is about the initial default dialog size, which is still too small.


16 years ago
Keywords: mozilla1.0.1 → mozilla1.3

Comment 27

16 years ago
Can't someone just fix this... it's been like this forever....

Comment 28

16 years ago
*** Bug 152727 has been marked as a duplicate of this bug. ***

Comment 29

16 years ago
I'm under the impression that now that (according to comments) the dialog
remembers its size some people think this bug is not important anymore. This is
not true! My window manager (Ion) does not let me resize the dialog because it
is what I think is called a "transient" in X11 terms and Ion creates transients
as sub-panes of the parent window without their own title bar (which is very
useful as it reduces screen clutter). So I'm stuck with the too small dialog
until someone finally checks in a (probably trivial) fix. To hell with not
harcoding sizes. Maybe this is not a pretty solution but this issue needs to be
fixed one way or another and an ugly temporary fix is better than none at all!

Can't someone at least post instructions here how to either hack the source code
or your preferences to get the dialog (the "Create in" part) larger?

Comment 30

15 years ago
Assigning bug back to the componen owner. I can't fix this.
Assignee: Kalle.Valo → ben
QA Contact: claudius → kasumi

Comment 31

15 years ago
Nav triage team: need info.  Kasumi, is this fixed now?
Whiteboard: [need info]

Comment 32

15 years ago
Nav triage team: need info.  Grace, is this fixed now?
QA Contact: kasumi → gbush

Comment 33

15 years ago
Created attachment 116590 [details]
current screen shot

Hard to tell from comments what correct size should be- this is what today's
trunk build 'file bookmarks' looks like

Comment 34

15 years ago
I had problems before with this, but it seems fine now. 

One might argue that the treeview should be more than two lines high to be a bit
more usable, but that should probably be in another bug...

Comment 35

15 years ago
No, I filed *this* bug because the *initial* vertical size of the tree view
being (much) too small. The screenshot in comment #33 shows no improvement.

Comment 36

15 years ago
Created attachment 116599 [details]
Screenshot of how it SHOULD look like

A minimum of 10 lines of directories are needed to be usable, IMO.

Comment 37

15 years ago
*** Bug 196458 has been marked as a duplicate of this bug. ***

Comment 38

15 years ago
Nav triage team: nsbeta1+/adt2
Assignee: ben → varga
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [need info] → [adt2]


15 years ago
Blocks: 196756
Priority: -- → P3
Target Milestone: --- → mozilla1.4alpha

Comment 39

15 years ago
1. This is not a PC-only issue, it also affects the Mac version of Mozilla.
Please change Hardware to All.
2. IMO, the default *horizontal* size is also too small. Ideally, the horizontal
width should automatically match the widest entry in the list.



15 years ago
Keywords: mozilla1.2, mozilla1.3
Hardware: PC → All


15 years ago
Flags: blocking1.4a?


15 years ago
Flags: blocking1.4a? → blocking1.4a-

Comment 40

15 years ago
I'm still having a problem with the vertical height of the Move Bookmarks
dialogs under Windows XP. This causes a problem since I can't get focus on the
OK/cancel button. If I manually resize the height of this dialog, I can close it
by  clicking OK. This only happens with classic theme only.


15 years ago
Target Milestone: mozilla1.4alpha → mozilla1.4beta

Comment 41

15 years ago
I'm going to close this one. 
Post-branch file bookmark issues are being addresseded in bug 199524, bug
199520, bug 199915 and bug 199531.
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 42

15 years ago
This bug is not a dupe of any of the others (none of them discuss the default 
vertical size of the File Bookmarks dialog).
It is definitely not fixed. I just tested the latest Win32 nightly (20030417) 
and this bug is still alive and kicking.

So... if it's not a dupe and it hasn't been fixed, why exactly is this bug 


Comment 43

15 years ago
I closed this one because the original problem has beeen fixed by using the
|rows| attribute. As far I know there are still problems only on Win XP.

Comment 44

15 years ago
all platforms- 4/18

Comment 45

14 years ago
This bug is present in:
Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8a) Gecko/20040430

It should be reopened.

Comment 46

14 years ago
I can't reproduce it on linux with new profile.

Comment 47

14 years ago
> I can't reproduce it on linux with new profile.

True. Ditto here (after copying my long list of bookmarks to the new profile).

However, there is a bug since the problem occurs with my old profile and Mozilla
doesn't provide a way to fix it (AFAIK).
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.