form action does not have the expected effect (does not delete email)

VERIFIED WORKSFORME

Status

()

--
minor
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: neversendmebulk, Assigned: alexsavulov)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052306

If I log into my email account, go to my inbox and let display a single mail,
there is a form button to delete the mail. If I click the button, the next mail
is displayed (as expected). But if I return to my inbox, the mail was not
deleted. It is still displayed in the inbox and can be opened again. Using
Netscape 4.77, Opera 6.0 or IE 6, the deleted mail is not in the inbox any more,
but in the deleted mail folder.

Reproducible: Always
Steps to Reproduce:
1. Log into email account.
2. Click inbox ("Posteingang").
3. Choose a certain email (does not matter which one).
4. Click form button "Löschen" (delete).
5. Return to inbox.

Actual Results:  The deleted mail was still in the inbox.

Expected Results:  The deleted mail should have been disappeared from the inbox
and moved to the deleted mail folder.

This is the form source in which the error occurs as far as I can see:

<form NAME="msgform"
ACTION="https://freemailng0606.web.de/online/logic/action.htm" METHOD="POST">

[...]
				
				<input class="a" TYPE="SUBMIT" 		NAME="rv_do_fwdmsg"		VALUE="Weiterleiten" >
				
				<input class="a" TYPE="SUBMIT" 		NAME="rv_do_delmsg"		VALUE="L&ouml;schen"
onclick="document.msgform.rv_js.value='yes';document.msgform.submit()" >
				<select class="a" 					NAME="rv_fid" 		
ONCHANGE="document.msgform.rv_do_mvmsg.value='yes';document.msgform.rv_js.value='yes';document.msgform.submit()">

[...]
									
				</select></form>



Easy workaround: checking the tickboxes of mails to be deleted in the inbox,
then pressing "Löschen" (delete) button.



In the inbox, a form is also used to delete mail. The source is:

				<form NAME="msgform" ACTION="/online/logic/action.htm" METHOD=POST>
					<input TYPE="HIDDEN" NAME="rv_goto"	
VALUE="/online/ordner/anzeigen.htm?si=cfJ.17bkMq.3cMxxi.f****&rv_showfid=0" >
					
[...]
								
										<input class="a" TYPE="SUBMIT" NAME="rv_do_showmsg"	VALUE="Lesen" onclick="lesenpost();" >&nbsp;

									
										<input class="a" TYPE="SUBMIT" NAME="rv_do_delmsg" VALUE="L&ouml;schen">&nbsp;
									


All other form actions in this example work properly. Hth.

Comment 1

17 years ago
Duplicate of 146775 ?

Comment 2

17 years ago
This works for me on build 2002-05-29-08-trunk win 98

Comment 3

17 years ago
resolving
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
Status: RESOLVED → VERIFIED

Comment 4

16 years ago
verifying. But if you still see this problem let me know.
You need to log in before you can comment on or make changes to this bug.