Closed Bug 1468949 Opened 3 years ago Closed 3 years ago

application crashed [@ mozilla::MediaStreamGraph::ApplyAudioContextOperation(mozilla::MediaStream*, nsTArray<mozilla::MediaStream*>

Categories

(Core :: Audio/Video: MediaStreamGraph, enhancement)

54 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1412231

People

(Reporter: jmaher, Unassigned)

Details

(Whiteboard: [test-verify cleanup])

while running tests in test-verify mode, we find many test cases that fail to run by themselves or solo in a short browser session.  We did this recently (bug 1405428) for crashtests (https://hg.mozilla.org/integration/mozilla-inbound/rev/b1fa2cf6ccae) and found many crashes.  Almost all of them are:
file:///builds/worker/workspace/build/tests/reftest/tests/dom/media/test/crashtests/952756.html | application crashed [@ mozilla::MediaStreamGraph::ApplyAudioContextOperation(mozilla::MediaStream*, nsTArray<mozilla::MediaStream*> const&, mozilla::dom::AudioContextOperation, void*)::AudioContextOperationControlMessage::RunDuringShutdown() + 0x22]


here is a try push:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=52fb07960b7c902d1f172b6967b75aceaeb90bd8&selectedJob=183031321&filter-searchStr=179

I figured I would file a bug since this reproduces easily.
Summary: medias → application crashed [@ mozilla::MediaStreamGraph::ApplyAudioContextOperation(mozilla::MediaStream*, nsTArray<mozilla::MediaStream*>
Flags: needinfo?(apehrson)
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(apehrson)
Resolution: --- → DUPLICATE
Duplicate of bug: 1412231
You need to log in before you can comment on or make changes to this bug.