Closed Bug 1468997 Opened 3 years ago Closed 1 month ago

Add a way to request a new locale directly through Pontoon

Categories

(Webtools Graveyard :: Pontoon, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED MOVED

People

(Reporter: spectre, Assigned: vishalcr7)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20180219150943

Steps to reproduce:

I went to Pontoon and wanted to add support for Sakha (Yakut) so that we could translate Common Voice. Sakha (ISO: sah) is not currently in Pontoon, so this involved sending a message to a Google Group which was pretty complicated.


Actual results:

The message was stuck in moderation. :)


Expected results:

It would be cool to be able to request a new locale through a nice interface in Pontoon.
Status: UNCONFIRMED → NEW
Component: General → Pontoon
Ever confirmed: true
Priority: -- → P3
Product: Localization Infrastructure and Tools → Webtools
Version: unspecified → other
The UI shoud live on the /teams page and work similarly to how requesting a project works from a /$TEAM page.

We could pull all required data for all CLDR locales, so PMs will no longer need to manually enter data like script, directon or population.

There should also be an option to request a non-CLDR locale.
Pulling CLDR data should also fix bug 1396915.
Assignee: nobody → vishaliitr7
Status: NEW → ASSIGNED
Mentor: m
(In reply to Matjaz Horvat [:mathjazz] from comment #2)
> Pulling CLDR data should also fix bug 1396915.

The script is available here:
https://github.com/mozilla-l10n/documentation/blob/2d1bec6e118c5d6537f5c76b87fe29f52082ef7c/tools/pontoon/adding_new_locale.md#using-a-script
Commit pushed to master at https://github.com/mozilla/pontoon

https://github.com/mozilla/pontoon/commit/b4dee05b069c270047c52e410bfac6e40a6ae375
Fix bug 1468997: Request new locale through /teams page (#1133)

Also: refactor requests view to share code when requesting new teams and new projects.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Commit pushed to master at https://github.com/mozilla/pontoon

https://github.com/mozilla/pontoon/commit/3d6707b5d0139d7e94ec904a528bcedf14d4dd1f
Bug 1468997: Disable Request Locale, r=me (#1153)

We should reconsider the UX for requesting new locales in order to meet
requirements from the PM team.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Mentor: m

It would be nice to lower the barrier to entry for new communities, so I wonder how can we move forward here.

Should we instead of to the PROJECT_MANAGERS send the email to https://lists.mozilla.org/listinfo/dev-l10n-new-locales?

Would it be helpful if in the followup step we add more fields (in addition to locale name and code) to the request form, which we typically ask for in the mailing list?

Flags: needinfo?(francesco.lodolo)

I think the current interface is quite ok for releasing (don't want to delay this any longer)

In future versions it might be cool to pull relevant information from CLDR and present it to the requester asking them to approve it, or edit it. If the required information is not in CLDR it might be nice to have a form for the user to submit it.

Not sure why the NI was directed at me, I'm not the decision maker here.

Flags: needinfo?(francesco.lodolo) → needinfo?(jbeatty)

Let's not add the mailing list to the picture, I expect that to go away. In an mhoye way. We might want to use discourse instead.

This also comes with a new question, and that's how we expect other installs to work here.

:flod, I remember talking to you when we disabled the original patch. I'm interested in hearing how the PMs would like the process of requesting a new locales to look like. I'd also like to make it easy to use for requesters, and as Axel hinted at compatible with the 3rd party installs.

In the original patch requester had to click the "Request new locale" button and fill in the locale name and code, which were then sent to the pontoon-team@mozilla.com mailing list. PMs would need to manually request additional information.

Using the mailing list came with a few benefits:

  1. Every Pontoon user has an email address, so the communication UX was straightforward.
  2. We used the same mailing list for processing project requests, so the feature was easy to implement and set up.
  3. The mailing address was configurable, so 3rd party installs could easily change it.

Does Discourse have an email-based interface per category that we could use as a mailing list replacement?

I'm not sure what decision I'm being asked to make here. Can someone raise that in a new comment please?

Flags: needinfo?(jbeatty)

(In reply to Jeff Beatty [:gueroJeff] from comment #12)

I'm not sure what decision I'm being asked to make here. Can someone raise that in a new comment please?

The question is where should Pontoon send new locale requests to (mailing list, Discourse, something else). Or more generally, how should the "Request new locale" feature look like.

:gueroJeff, I take your +1 as an r+ to the feature described in Comment 11, but with Discourse being the target of the request instead of the mailing list. Could you please confirm that? :)

I'd also like to ask Flod and Peiying for a review of the above "spec".

Personally, I'm skeptical of using Discourse because:

  1. It adds a barrier of signing up/in to a new platform
  2. It's inconsistent with the "Request new project" feature

So if we choose to go with Discourse, I suggest we:

  1. Measure what percentage of requests made in Pontoon result in a request made on Discourse
  2. In a followup, consolidate targets of the Request locale/project features
Flags: needinfo?(pmo)
Flags: needinfo?(jbeatty)
Flags: needinfo?(francesco.lodolo)

(In reply to Matjaz Horvat [:mathjazz] from comment #15)

(In reply to Jeff Beatty [:gueroJeff] from comment #12)
:gueroJeff, I take your +1 as an r+ to the feature described in Comment 11, but with Discourse being the target of the request instead of the mailing list. Could you please confirm that? :)

I can confirm my support of that for the following reasons:

  • mailing-lists are following the path of IRC
  • Discourse appears to be the preferred replacement
  • having a public archive where other existing locales can welcome and support new communities is an important part of integrating into Mozilla.
  • The Pontoon managers email alias doesn't allow for that level of transparency.

I'd also like to ask Flod and Peiying for a review of the above "spec".

Personally, I'm skeptical of using Discourse because:

  1. It adds a barrier of signing up/in to a new platform
  2. It's inconsistent with the "Request new project" feature

I understand your concern around #1. I don't share your concern for #2. More information is necessary to set up a locale than setting up a new project for an existing locale. That difference may justify the inconsistency.

So if we choose to go with Discourse, I suggest we:

  1. Measure what percentage of requests made in Pontoon result in a request made on Discourse
  2. In a followup, consolidate targets of the Request locale/project features
    +1
Flags: needinfo?(jbeatty)

(In reply to Jeff Beatty [:gueroJeff] from comment #16)

  • mailing-lists are following the path of IRC
  • Discourse appears to be the preferred replacement
  • having a public archive where other existing locales can welcome and support new communities is an important part of integrating into Mozilla.
  • The Pontoon managers email alias doesn't allow for that level of transparency.

While transparency and community integration are fundamental, I don't think they are necessarily relevant when it comes to requesting a new language in Pontoon. dev-l10n-new-locales has been hardly useful in that sense, actually counterproductive in some cases (e.g. one-person team promoting the idea that we should allow a single person to translate projects like Firefox).

If we move dev-l10n to Discourse (and I don't see why we shouldn't), that would take better care of the community integration part.

Have we considered using GitHub instead?

  • Templates seems to fit our needs.
  • It's public.
  • It would be possible to assign this to a PM as part of a triage.
  • It would be easy to search for previous requests.
  • You can still watch the project if you're interested.
Flags: needinfo?(francesco.lodolo)

Here are my two cents, :).

  • Pontoon: Preferred. This is aligned with existing features such as Add More Projects and Add New Locales (to a project). A form pops up. Once filled, a project must be added. I also assume the person makes the request has an account on Pontoon, and we can tie the person to the locale/project and likely make the person the locale manager.
    Question: are the PMs notified just like the project request we get? This would allow follow-up questions.
  • Discourse: if this is about engagement and increase our presence there, we can make new locale request available but it links the request back to the Pontoon feature. Too often, I get requests through emails and indirectly through Discourse, once the project is set up, I don't always get an owner. Getting people to Pontoon takes time. In the process, the interests drop.
  • GitHub: I like the idea especially it is transparent and history is easily traceable and discoverable. Is this too much to ask for a new comer to register in GitHub and file an issue?

Personally, I would like to see the actual requests happening in Pontoon, but the start of the conversation can be from multiple sources and they all lead to Pontoon to make the request formal.

Flags: needinfo?(pmo)

I agree with Peiying here, that requesting a new language should definitely require an account on Pontoon. This is something we can easily explain to people, and as she says we can make that person the manager. They'll need an account on Pontoon to start localising anyway.

I think registering on GitHub is ok but not ideal, most people will have a GitHub account or can make one fairly easily, but it adds an extra dependency on Microsoft / another US company, such that it might be difficult for people in certain countries.

*This bug has been moved to GitHub.*

*Please check it out on https://github.com/mozilla/pontoon/issues.*
Status: REOPENED → RESOLVED
Closed: 3 years ago1 month ago
Resolution: --- → MOVED
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.