Japanese fonts are rendered as '?'

VERIFIED INVALID

Status

()

VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: davidmaxwaterman+bugzilla-daemon, Assigned: tetsuroy)

Tracking

({intl})

Trunk
SGI
IRIX
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; IRIX IP32; en-US; rv:1.0.0+) Gecko/20020522
BuildID:    2002052223

Japanese fonts are rendered as '?'.

Reproducible: Always
Steps to Reproduce:
1.go to above site
2.see that character in text field is rendered as a '?'
3.

Actual Results:  character in text field is rendered as a '?'

Expected Results:  should be rendered as a japanese character (ie works fine on
Windows).
-> Int
Assignee: Matti → yokoyama
Component: Browser-General → Internationalization
QA Contact: imajes-qa → ruixu

Updated

17 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 2

17 years ago
I don't have such kind of IRIX system to confirm.
(Reporter)

Comment 3

17 years ago
> ------- Additional Comment #2 From Yuying Long 2002-05-24 18:05 -------
> I don't have such kind of IRIX system to confirm.

How should we procede then?

Perhaps you should contact SGI's engineer responsible for netscape and mozilla
Victor A. Riley <var@engr.sgi.com>. I sent him an email about it right after
logging this bug.

Max.
(Assignee)

Comment 4

17 years ago
thanx, Max

Comment 5

17 years ago
This works for me using RC3 (on IRIX) with the japanese font pack installed. 
The fonts will be rendered as '?' if you do not have the appropriate fonts 
installed.

Comment 6

17 years ago
To clarify:
To view japanese fonts on IRIX you need to install:
WorldView_base_jp
which is an IRIX package.
(Reporter)

Comment 7

17 years ago
All works as planned when I have the IRIX Japanese WorldView subsystem installed.

Not sure why this is necessary when a Mozilla install for both Linux and Windows
doesn't require any additional s/w, but I guess I don't really care.

Please close this, thanks.

Comment 8

17 years ago
Max,
   As reporter you should be able to close this bug. You should also be able to
change things like Platform and OS.
(Reporter)

Comment 9

17 years ago
My error for not having the correct s/w installed. Closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 10

17 years ago
Mark as verified per comment above.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.