Closed Bug 1469075 Opened Last year Closed Last year

Inspector tab order is changed after using the browser content toolbox

Categories

(DevTools :: Framework, defect, P2)

defect

Tracking

(firefox63 wontfix, firefox64 fixed)

RESOLVED FIXED
Firefox 64
Tracking Status
firefox63 --- wontfix
firefox64 --- fixed

People

(Reporter: jdescottes, Assigned: daisuke)

References

Details

Attachments

(5 files, 8 obsolete files)

46 bytes, text/x-phabricator-request
jdescottes
: review+
Details | Review
46 bytes, text/x-phabricator-request
jdescottes
: review+
Details | Review
46 bytes, text/x-phabricator-request
jdescottes
: review+
Details | Review
46 bytes, text/x-phabricator-request
jdescottes
: review+
Details | Review
46 bytes, text/x-phabricator-request
jdescottes
: review+
Details | Review
STRs:
- open firefox
- open devtools
- open browser content toolbox
- close browser content toolbox 
- close & reopen devtools

ER: tab order should not be modified 
AR: inspector moves in 4th position

The tabs order preference was updated to webconsole,jsdebugger,memory when closing the browser content toolbox.
Summary: Inspector tab moves after using the browser content toolbox → Inspector tab order is changed after using the browser content toolbox
Blocks: 1226272
See Also: → 1467000, 1478465
See Also: 1478465
Duplicate of this bug: 1478465
Priority: P3 → P2
I'll investigate this one.
For example, assuming the tabs of DevTools are “Inspector”, “Debugger” and “Console”.
Then, assuming the Browser Content Toolbox displays “Console”, “Debugger” and “Memory”. 
When close the Browser Content Toolbox,  devtools.toolbox.tabsOrder preference will be `console,debugger,memory`. 
At the same time, the order as well of tabs on DevTools is affected, the order will be “Console”, “Debugger”, “Inspector” along to the preference. This is the cause.
On the one hand, in case of Browser Toolbox, due to launch as new Firefox instance, the preference is not shared, so we can set the order respectively.

In this time, I want to fix to be able re-ordering in each toolbox such as DevTools or Browser Content Toolbox, if possible.
Can we also fix the ordering for tabs that display conditionally? e.g. the React tab? (bug 1467000)

That seems more likely to affect our users than the ordering from the Browser Content Toolbox.
Depends on D4407
Comment on attachment 9004421 [details]
Bug 1469075 - Part 2: Remove mouseout handling. r=jdescottes

Julian Descottes [:jdescottes][:julian] has approved the revision.
Attachment #9004421 - Flags: review+
Depends on: 1488302
Attachment #9004421 - Attachment is obsolete: true
Attachment #9004422 - Attachment is obsolete: true
If the amount of mouse moving at mousemove event will exceed to both ends of tabs, the dragging tab will move to exceed the ends. This patch makes to avoid this.

Depends on D4906
Comment on attachment 9006161 [details]
Bug 1469075 - Part 1: Remove mouseout handling. r=jdescottes

Julian Descottes [:jdescottes][:julian] has approved the revision.
Attachment #9006161 - Flags: review+
Attachment #9006162 - Attachment is obsolete: true
Attachment #9006161 - Attachment is obsolete: true
Assignee: nobody → dakatsuka
Status: NEW → ASSIGNED
Attachment #9004423 - Attachment is obsolete: true
Attachment #9004420 - Attachment is obsolete: true
Attachment #9006805 - Attachment is obsolete: true
Attachment #9004425 - Attachment is obsolete: true
Depends on D5121

Depends on D5121
Attachment #9006806 - Attachment description: Bug 1469075 - Part 6: Add test for hidden extension. r=jdescottes → Bug 1469075 - Part 3: Add test for hidden extension. r=jdescottes
Attachment #9006804 - Attachment description: Bug 1469075 - Part 3: Keep add-ons id till uninstall. r=jdescottes → Bug 1469075 - Part 2: Keep add-ons id till uninstall. r=jdescottes
Attachment #9006803 - Attachment description: Bug 1469075 - Part 2: Save tabs order preference with hidden tools. r=jdescottes → Bug 1469075 - Part 1: Save tabs order preference with hidden tools. r=jdescottes
Comment on attachment 9006804 [details]
Bug 1469075 - Part 2: Keep add-ons id till uninstall. r=jdescottes

Julian Descottes [:jdescottes][:julian] has approved the revision.
Attachment #9006804 - Flags: review+
Comment on attachment 9006803 [details]
Bug 1469075 - Part 1: Save tabs order preference with hidden tools. r=jdescottes

Julian Descottes [:jdescottes][:julian] has approved the revision.
Attachment #9006803 - Flags: review+
Comment on attachment 9006806 [details]
Bug 1469075 - Part 3: Add test for hidden extension. r=jdescottes

Julian Descottes [:jdescottes][:julian] has approved the revision.
Attachment #9006806 - Flags: review+
Comment on attachment 9007147 [details]
Bug 1469075 - Part 4: Add test with secondary toolbox. r=jdescottes

Julian Descottes [:jdescottes][:julian] has approved the revision.
Attachment #9007147 - Flags: review+
Comment on attachment 9008598 [details]
Bug 1469075 - Part 5: Add unit test for a function which make tabs order. r?jdescottes

Julian Descottes [:jdescottes][:julian] has approved the revision.
Attachment #9008598 - Flags: review+
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e2e4170b4e0f
Part 1: Save tabs order preference with hidden tools. r=jdescottes
https://hg.mozilla.org/integration/mozilla-inbound/rev/503622a2654a
Part 2: Keep add-ons id till uninstall. r=jdescottes
https://hg.mozilla.org/integration/mozilla-inbound/rev/738621450246
Part 3: Add test for hidden extension. r=jdescottes
https://hg.mozilla.org/integration/mozilla-inbound/rev/f398fb8f6225
Part 4: Add test with secondary toolbox. r=jdescottes
https://hg.mozilla.org/integration/mozilla-inbound/rev/6096baf109f9
Part 5: Add unit test for a function which make tabs order. r=jdescottes
Duplicate of this bug: 1467000
Depends on: 1492101
This likely affected 63 as well, and I'm wontfixing for 63 since we're about to release it next week.
You need to log in before you can comment on or make changes to this bug.