Closed Bug 1469201 Opened 3 years ago Closed 3 years ago

Intermittent testing\marionette\harness\marionette_harness\tests\unit\test_quit_restart.py TestQuitRestart.test_reset_context_after_quit_by_using_context | MarionetteException: Please start a session when Gecko 62

Categories

(Testing :: Marionette, defect)

Version 3
defect
Not set
normal

Tracking

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 unaffected, firefox62- affected)

RESOLVED DUPLICATE of bug 1461789
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 - affected

People

(Reporter: apavel, Unassigned)

Details

Central as beta simulation:

Treeherder link: https://treeherder.mozilla.org/#/jobs?repo=try&revision=7d593e4769ed90916840dfa6679b2c4e43268844&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=usercancel&filter-resultStatus=runnable&selectedJob=183545290

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=183545290&repo=try&lineNumber=44209

11:48:59     INFO -  [Parent 8180, Main Thread] WARNING: Need TabChild to get the nativeWindow from!: file z:/build/build/src/widget/PuppetWidget.cpp, line 1220
11:48:59     INFO -  ++DOMWINDOW == 17 (00000234698D0C00) [pid = 8180] [serial = 17] [outer = 00000234665FFE00]
11:48:59     INFO -  [Parent 8180, Main Thread] WARNING: Need TabChild to get the nativeWindow from!: file z:/build/build/src/widget/PuppetWidget.cpp, line 1220
11:48:59     INFO -  [Child 2084, Main Thread] WARNING: No CID found when attempting to map contract ID: file z:/build/build/src/xpcom/components/nsComponentManager.cpp, line 505
11:48:59     INFO -  [Child 2084, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file z:/build/build/src/xpcom/base/nsSystemInfo.cpp, line 119
11:48:59     INFO -  ++DOCSHELL 000001BE6AC47800 == 1 [pid = 2084] [id = {bdc43a1b-785e-4c59-acbd-ebdc53af342b}]
11:48:59     INFO -  ++DOMWINDOW == 1 (000001BE6AC12400) [pid = 2084] [serial = 1] [outer = 0000000000000000]
11:48:59     INFO -  ++DOCSHELL 000001BE6AC49800 == 2 [pid = 2084] [id = {122a6347-f9de-43e9-9a8e-c49f0b85eec6}]
11:48:59     INFO -  ++DOMWINDOW == 2 (000001BE6AC13C00) [pid = 2084] [serial = 2] [outer = 0000000000000000]
11:48:59     INFO -  [Child 2084, Main Thread] WARNING: Fallback to BasicLayerManager: file z:/build/build/src/dom/ipc/TabChild.cpp, line 2843
11:48:59     INFO -  [Child 2084, Main Thread] WARNING: Fallback to BasicLayerManager: file z:/build/build/src/dom/ipc/TabChild.cpp, line 2843
11:48:59     INFO -  1529236139915	Marionette	DEBUG	Waiting for startup tests...
11:48:59     INFO -  ++DOMWINDOW == 3 (000001BE70170000) [pid = 2084] [serial = 3] [outer = 000001BE6AC12400]
11:48:59     INFO -  ++DOMWINDOW == 4 (000001BE6ACEA400) [pid = 2084] [serial = 4] [outer = 000001BE6AC13C00]
11:48:59     INFO -  1529236139956	Marionette	INFO	Listening on port 2828
11:48:59     INFO -  ++DOMWINDOW == 5 (000001BE6ACF0400) [pid = 2084] [serial = 5] [outer = 000001BE6AC12400]
11:49:00     INFO -  ++DOMWINDOW == 6 (000001BE7016E000) [pid = 2084] [serial = 6] [outer = 000001BE6AC13C00]
11:49:00     INFO -  Assertion failure: param.type.Tag() != nsXPTType::T_JSVAL (JSVals are marked as needing cleanup (even though they don't)), at z:/build/build/src/js/xpconnect/src/XPCWrappedNative.cpp:1732
11:49:00     INFO -  #01: XRE_GetBootstrap[Z:\task_1529235203\build\application\firefox\xul.dll +0x4c9e446]
11:49:00     INFO -  #02: XRE_GetBootstrap[Z:\task_1529235203\build\application\firefox\xul.dll +0x4c8857c]
11:49:00     INFO -  #03: XRE_GetBootstrap[Z:\task_1529235203\build\application\firefox\xul.dll +0x4c86a01]
11:49:00     INFO -  #04: XRE_GetBootstrap[Z:\task_1529235203\build\application\firefox\xul.dll +0x4bd362c]
11:49:00     INFO -  #05: XRE_GetBootstrap[Z:\task_1529235203\build\application\firefox\xul.dll +0x4b7b234]
11:49:00     INFO -  #06: XRE_GetBootstrap[Z:\task_1529235203\build\application\firefox\xul.dll +0x4b5d0d2]
11:49:00     INFO -  #07: XRE_GetBootstrap[Z:\task_1529235203\build\application\firefox\xul.dll +0x50ecf78]
11:49:00     INFO -  #08: XRE_GetBootstrap[Z:\task_1529235203\build\application\firefox\xul.dll +0x50ecd33]
11:49:00     INFO -  #09: XRE_GetBootstrap[Z:\task_1529235203\build\application\firefox\xul.dll +0x50de4b0]
11:49:00     INFO -  #10: XRE_GetBootstrap[Z:\task_1529235203\build\application\firefox\xul.dll +0x55a3608]
11:49:00     INFO -  #11: XRE_GetBootstrap[Z:\task_1529235203\build\application\firefox\xul.dll +0x5630355]
11:49:00     INFO -  #12: ??? (???:???)
11:50:58    ERROR -  TEST-UNEXPECTED-ERROR | testing\marionette\harness\marionette_harness\tests\unit\test_quit_restart.py TestQuitRestart.test_reset_context_after_quit_by_using_context | MarionetteException: Please start a session
11:50:58     INFO -  Traceback (most recent call last):
11:50:58     INFO -    File "Z:\task_1529235203\build\venv\lib\site-packages\marionette_harness\marionette_test\testcases.py", line 159, in run
11:50:58     INFO -      testMethod()
11:50:58     INFO -    File "Z:\task_1529235203\build\tests\marionette\tests\testing\marionette\harness\marionette_harness\tests\unit\test_quit_restart.py", line 321, in test_reset_context_after_quit_by_using_context
11:50:58     INFO -      "Not in content context after quit with using_context")
11:50:58     INFO -    File "c:\mozilla-build\python\Lib\contextlib.py", line 35, in __exit__
11:50:58     INFO -      self.gen.throw(type, value, traceback)
11:50:58     INFO -    File "Z:\task_1529235203\build\venv\lib\site-packages\marionette_driver\marionette.py", line 1437, in using_context
11:50:58     INFO -      self.set_context(scope)
11:50:58     INFO -    File "Z:\task_1529235203\build\venv\lib\site-packages\marionette_driver\marionette.py", line 1414, in set_context
11:50:58     INFO -      {"value": context})
11:50:58     INFO -    File "Z:\task_1529235203\build\venv\lib\site-packages\marionette_driver\decorators.py", line 26, in _
11:50:58     INFO -      return func(*args, **kwargs)
11:50:58     INFO -    File "Z:\task_1529235203\build\venv\lib\site-packages\marionette_driver\marionette.py", line 729, in _send_message
11:50:58     INFO -      raise errors.MarionetteException("Please start a session")
11:50:58     INFO -  TEST-INFO took 121862ms
11:50:58     INFO -  Application command: Z:\task_1529235203\build\application\firefox\firefox.exe -no-remote -marionette -profile c:\users\task_1529235203\appdata\local\temp\tmpfcgttl.mozrunner
11:50:58     INFO -  [5864, Main Thread] WARNING: Failed to load startupcache file correctly, removing!: file z:/build/build/src/startupcache/StartupCache.cpp, line 217
11:50:58     INFO -  [5864, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file z:/build/build/src/extensions/cookie/nsPermissionManager.cpp, line 2910
11:50:59     INFO -  1529236259631	Marionette	DEBUG	Received observer notification profile-after-change
11:50:59     INFO -  ++DOCSHELL 000001185C40E000 == 1 [pid = 5864] [id = {739cc13e-8377-47cc-9fd7-d4c5ada51bd7}]
11:50:59     INFO -  ++DOMWINDOW == 1 (000001185C8EFC00) [pid = 5864] [serial = 1] [outer = 0000000000000000]
11:50:59     INFO -  ++DOMWINDOW == 2 (000001185CF26C00) [pid = 5864] [serial = 2] [outer = 000001185C8EFC00]
11:50:59     INFO -  1529236259732	Marionette	DEBUG	Received observer notification command-line-startup
11:50:59     INFO -  1529236259732	Marionette	DEBUG	Received observer notification nsPref:changed
11:50:59     INFO -  1529236259732	Marionette	DEBUG	Init aborted (running=false, enabled=true, finalUIStartup=false)
11:50:59     INFO -  ++DOCSHELL 000001185D08A800 == 2 [pid = 5864] [id = {5c87d382-f4d0-42e1-8007-42a26e432584}]
11:50:59     INFO -  ++DOMWINDOW == 3 (000001185C8F5C00) [pid = 5864] [serial = 3] [outer = 0000000000000000]
11:50:59     INFO -  ++DOMWINDOW == 4 (000001185D057000) [pid = 5864] [serial = 4] [outer = 000001185C8F5C00]
11:50:59     INFO -  ++DOCSHELL 000001185D09F000 == 3 [pid = 5864] [id = {89370fc8-ce08-4b65-89b1-14b047b7d2a5}]
11:50:59     INFO -  ++DOMWINDOW == 5 (000001185B3E8C00) [pid = 5864] [serial = 5] [outer = 0000000000000000]
11:50:59     INFO -  ++DOMWINDOW == 6 (000001185B68D400) [pid = 5864] [serial = 6] [outer = 000001185B3E8C00]
11:50:59     INFO -  [5864, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file z:/build/build/src/netwerk/protocol/res/SubstitutingProtocolHandler.cpp, line 342
11:50:59     INFO -  ++DOMWINDOW == 7 (000001185B697C00) [pid = 5864] [serial = 7] [outer = 000001185C8F5C00]
This is just bug 1461789.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1461789
You need to log in before you can comment on or make changes to this bug.