Html table with invalid tags gets truncated

RESOLVED DUPLICATE of bug 58917

Status

()

Core
Layout: Tables
P3
normal
RESOLVED DUPLICATE of bug 58917
16 years ago
16 years ago

People

(Reporter: Jeremy Van Grinsven, Assigned: karnaze (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052306

There should be 6 complete lists shown in the table.  The last part gets
truncated.  It is in the source and html is correct, but it doesn't get rendered.

Reproducible: Always
Steps to Reproduce:
1. Load attached html

Actual Results:  6th list is truncated

Expected Results:  display the complete list included in the source html

cutting up the <paradigm> text causes the text to display correctly.  These
should be ignored by the parser.
(Reporter)

Comment 1

16 years ago
Created attachment 84996 [details]
testcase

Comment 2

16 years ago
 Some part of the page is not rendered at all. Might be a style-system problem. 
Setting the priority.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Priority: -- → P3

Comment 3

16 years ago
When I check the testcase, I think that it is caused by uncorrectly handle user
define tags.

There are  many '<paradigm>' in that testcase, when using DOM inspector, 
it shows that mozilla treat it as an container, the content tree is very deep.
for this testcase, the frame tree is also very deep.
So there are render problem for this page.


That reminds me that once jkeiser said that mozilla treat unknown tag badly. 
add jkerser to cc list.

Comment 4

16 years ago
One question: 
Is it better for mozilla create frame for unknown tags only when those elements
have valid display property such as display:block?

bz, your opinion?
The have a valid display in this case.  display:inline.

Further, no creating those frames would lead to not showing any of the content
on this page.

This is basically bug 58917

*** This bug has been marked as a duplicate of 58917 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.