Closed Bug 1469406 Opened 2 years ago Closed 2 years ago

Google Hangouts/Meet - mic no longer is broadcast in Firefox 60.0.2

Categories

(Core :: WebRTC, defect, P2)

60 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: daniel.vandersluis, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180605171542

Steps to reproduce:

1. Connect to a google meet meeting
2. Give permission to access the microphone
3. Make sure microphone isn't muted in the app


Actual results:

The sound levels widget in Google Meet shows change when talking, however no other participants can hear me.


Expected results:

Other participants should hear mic audio.
According to reddit (https://www.reddit.com/r/firefox/comments/8s24pz/google_hangouts_meet_audio_is_broken_on_ff_60/) other people are experiencing this as well.
Summary: Google Meet - mic no longer is broadcast in Firefox 60.0.2 → Google Hangouts/Meet - mic no longer is broadcast in Firefox 60.0.2
Can confirm - I am also experiencing this using these steps.
I can confirm this bug too, I was using Meet with Firefox with version 59 and it worked fine.
I tried reproducing this issue with Google hangout on 

Build ID 	20180605171542
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:60.0) Gecko/20100101 Firefox/60.0

We observed some audio issue but other participants were able to hear my sound not clearly though. Based on others could reproduce same issues, I am placing this under Core:audio/video so someone can look into it. Thanks!
Component: Untriaged → Audio/Video
Product: Firefox → Core
It's important to note that, at least for me, this affects Google Meet, not the older Hangouts product. To reproduce:

1. https://meet.google.com/
2. Start a new meeting
3. Invite someone else to join
4. Speak into your mic - confirm that the other party can't hear you

I've confirmed this is still an issue for me on

Build ID 20180614135649
Version 61.0b14
User Agent Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
FWIW, it seems to work on 62.
Hmm, no luck reproducing on 60 either.
Ok, that's interesting, the audio was working initially, but stopped working after a minute.
Status: UNCONFIRMED → NEW
Component: Audio/Video → WebRTC
Ever confirmed: true
Actually, nevermind, it seems to be working still.

I will attempt some interop cases with different browsers on the other end.
Here's the version I am currently running:

Name: Firefox
Version: 60.0.2
Build ID: 20180605171542
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:60.0) Gecko/20100101 Firefox/60.0


I was able to successfully use the mic in Google Hangouts Meet yesterday. It makes me think this might be a Google issue and not a Firefox issue. At any rate, I am no longer experiencing this bug.
I've just re-tested this evening, and it seems to work again. I think the timing of the breakage was coincidentally close to a Firefox update, which led me to suspect browser rather than the service itself.

I'll revisit on Monday and confirm.
I just tried a 3-way conference with Firefox 60, Firefox 62, and Chrome 67, and everything seems to work fine.

Forcing TURN-only operation breaks things, but that seems to be because meet doesn't configure a TURN server. If video flows fine, the lack of a TURN server is unlikely to break audio, unless meet is doing something like routing video through an SFU (on a public address) but allowing audio to flow peer-to-peer. I don't see any evidence that this is the case.

I have also tried a call using 62 with the NAT simulator enabled, and that works fine also.


Daniel, is this still broken for you? Maybe there was some issue with meet that has been fixed in the meantime?
Rank: 15
Priority: -- → P2
Flags: needinfo?(daniel.vandersluis)
Hey Byron, we tried a quick call in Google Meet (two participants, both on Firefox 60.0.0.2) and we were both able to hear each other. We didn't do a very long call so I can't speak to your previous comment about the audio stopping after some time, but in a short call there were no issues.
Flags: needinfo?(daniel.vandersluis)
Ok, cool, it looks like this was a meet issue. Thanks for the heads-up though!
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.