Closed Bug 1469418 Opened Last year Closed Last year

Original "New Folder" name persists in New Bookmark dialog after renaming

Categories

(Firefox :: Bookmarks & History, defect, P1)

61 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 --- verified

People

(Reporter: agashlin, Assigned: standard8)

References

Details

(Keywords: regression, Whiteboard: [fxsearch])

Attachments

(1 file)

Steps to reproduce:
1. Create a bookmark with Ctrl-D
2. Click the "Show all the bookmarks folders" down arrow to display the folder list
3. Click the "New Folder" button. (The name in the Folder dropdown becomes "New Folder")
4. Enter a new name for the folder

Actual Result:
The folder is renamed, but in the Folder dropdown the name still shows as "New Folder". This persists even when selecting another folder and then returning to the renamed new folder.

Expected Result:
"New Folder" name shouldn't appear anymore, should be replaced with the new name.

Regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=c843c0d78a0e065b8dfafcdba9fe753da100340b&tochange=72b42d9da6b7d5a7c40cd284350d0aa2091b7b57

Related to bug 1460579?
Flags: needinfo?(standard8)
Keywords: regression
Priority: -- → P1
Whiteboard: [fxsearch]
Assignee: nobody → standard8
Status: NEW → ASSIGNED
Flags: needinfo?(standard8)
Comment on attachment 8986167 [details]
Bug 1469418 - Fix updating the folder name in the bookmarks properties menulist when it changes.

Marco Bonardo [::mak] has approved the revision.

https://phabricator.services.mozilla.com/D1701
Attachment #8986167 - Flags: review+
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1cb216fe1378
Fix updating the folder name in the bookmarks properties menulist when it changes. r=mak
https://hg.mozilla.org/mozilla-central/rev/1cb216fe1378
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
I’ve reproduced this issue on Firefox 62.0a1 (2018-06-18) under Windows 10 x64. 

This behavior no longer occurs on Firefox 62.0b7 on Windows 10 x64 an Ubuntu 16.04 x64, but on macOS 10.13, the issue is still present, the name in the Folder dropdown remains New Folder.

Note, also, that on Windows platform is a missing space between the icon and the folder’s name in the Folder dropdown header - see screenshot: https://drive.google.com/open?id=1KSQp8_oSfxJ4610HmsaHTVYCpBZ0vijP .
(In reply to Anca Soncutean [:Anca], Desktop Release QA from comment #6)
> Note, also, that on Windows platform is a missing space between the icon and
> the folder’s name in the Folder dropdown header - see screenshot:
> https://drive.google.com/open?id=1KSQp8_oSfxJ4610HmsaHTVYCpBZ0vijP .

That's bug 1468080
(In reply to Anca Soncutean [:Anca], Desktop Release QA from comment #6)
> This behavior no longer occurs on Firefox 62.0b7 on Windows 10 x64 an Ubuntu
> 16.04 x64, but on macOS 10.13, the issue is still present, the name in the
> Folder dropdown remains New Folder.

This works fine for me on 62.0b7 on MacOS 10.13.
Sorry for not being explicit enough in the previous comment.
On Windows and Ubuntu platforms, I noticed that after writing the name of the New Folder, the changes were made instantly as I click on the dropdown arrow. 
On macOs(s) these changes occur only if before clicking on the dropdown arrow, the folder renaming is completed with a click on the white space or the [Enter] key. 

After further investigation, I encounter an ugly behaviour triggered by the mentioned above information (mac version - 10.13 and 10.11).

Steps to reproduce:
1. Bookmark any webpage via Star icon
2. Click on the "Show all the bookmarks folders" down arrow 
3. Click on the "New Folder" button (folder renaming is not necessary)
4. Click on the "Hide" up arrow 
5. Click again on the "Show all the bookmarks folders" down arrow 

Actual result: 
The Folder dropdown is not usable anymore and only the text input-field of the folder created at step 3 is displayed. Any attempt to bookmark other web pages opens the same broken panel. This is fixed only after browser restart.

This is not a recent regression, I restrained the regression range only to to followings: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0e41d07a703f19224f60b01577b2cbb5708046c9&tochange=09a4282d1172ac255038e7ccacfd772140b219e2

See the screencast of this behavior: 
https://drive.google.com/open?id=14sSrbkq416OyVOldgVkD2QUt9ziotNR_
Thanks for the clarification, to me that's a separate bug - it is about what happens when the tree view looses focus on Mac, which in this case appears to be not loosing focus at all.

Please file it as a separate bug, as it now works when pressing the enter key that's what was being fixed by this bug.
Based on the comments above I will mark this issue as verified fixed. 
The behavior mention in comment 9 is described in bug 1475489.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.