product size varies drastically between releases when building from source

VERIFIED INVALID

Status

SeaMonkey
Build Config
--
critical
VERIFIED INVALID
16 years ago
13 years ago

People

(Reporter: Deleted User, Assigned: hacker formerly known as seawood@netscape.com)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Since mozilla still does not install to where I point the --prefix I still just
tar everything in mozilla/dist and extract it in /usr/mozilla. Maybe you could
write a paper about how to get a clean install.

My experiences are that some earlier versions got me some gig's of binaries
after compiling. Then, 0.9.7 actually was "only" 245 Mb "small". The following
0.9.x releases were about 1 gig size again. RC1 was still more than 700 Mb big.
Then RC2 was only 183 Mb "small". This is the smallest size ever. Now RC3 is
863Mb big.

I don't understand these drastic changes, they must be related to some more or
less softlinks from inside mozilla/dist or whatever. but, I marked this problem
as crucial because if 1.0Final is still that big for me then I will not use it.
The difference in size is because you are building the debug version, which is
the default.  Click on the Build Configurator link at
http://www.mozilla.org/build/unix.html to get the list of current build options.
  The one that you'd be most interested in is --disable-debug. The 'make
install' bug (bug 56601) has been fixed on the  trunk for awhile and was just
checked into the 1.0 branch earlier this afternoon.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 2

15 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.