nonexistant sites should not be added to session history SH

VERIFIED FIXED

Status

()

Core
Document Navigation
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: Alec Flett, Assigned: Chris Waterson)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
If you have are viewing a valid site, and then type in a bogus url
like http://www.alskdjflaskd.com/, the DNS lookup will fail, but the site will
be added to your session history.
This means that if you hit back, it appears to do nothing, because it goes
"back" from the nonexistant site, to the site you were looking at, which is
still on scree en.

Updated

19 years ago
Assignee: don → waterson
QA Contact: leger → claudius

Comment 1

19 years ago
Chris, is this you or someone else?
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13

Updated

19 years ago
Component: Browser-General → History
(Assignee)

Updated

18 years ago
Target Milestone: M13 → M20

Comment 2

18 years ago
Looks like almost a DUP of bug 11325, "bad URLs added to browser history", 
ASSIGNED, M15 - the difference being that that bug is about the global
history and this one is about the session history. This bug also seems
responsible for "empty" entries on the Go menu.
Summary: nonexistant sites should not be added to history → nonexistant sites should not be added to session history SH

Comment 3

18 years ago
lets be sure and keep these separated for now. with the new changes to come I think SH and global will be handled differently.

Comment 4

18 years ago
*** Bug 29224 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
*** Bug 31037 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
wanna reel in the milestone here? similar and related bug 11325 is M15 (and rightly so)

Comment 7

18 years ago
*** Bug 31496 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
cc'ing radha

Comment 9

18 years ago
This should be fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 10

18 years ago
VERIFIED Fixed on all platforms with the 200042109 builds
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.