Closed Bug 1469598 Opened Last year Closed Last month

Broken header layout in RTL mode

Categories

(DevTools :: Accessibility Tools, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Honza, Unassigned)

Details

Attachments

(1 file)

Attached image rtl.png
STR:
1. Launch Firefox. Make sure to switch to RTL mode (e.g. setting intl.uidirection pref to `1`)
2. Navigate to any website
3. Press the F12 key
4. Enable Accessibility tab in Toolbox Settings if needed
5. Select the Accessibility tab
6. Expand the root document item.

BUG: A little white gap is created at the right side of the Header (just after the 'Role' label). This gap is transparent, so I can see e.g. the blue selection if it's underneath.

7. Close the root document item.

BUG: The gap disappears and the 'Role' label is moved to the right and partially hidden.

Changing size of the browser window (triggers re-layout) fixes the problem.

See the attached screenshot (and highlighted red areas in it).

Honza
Priority: -- → P3

Are you still able to reproduce this?

Flags: needinfo?(odvarko)

(In reply to Itiel from comment #1)

Are you still able to reproduce this?

No, this seems to be fixed now.

Thanks for the note!
Closing
Honza

Status: NEW → RESOLVED
Closed: Last month
Flags: needinfo?(odvarko)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.