Error this.pageListener is undefined in AboutPrivateBrowsingHandler.jsm

RESOLVED FIXED in Firefox 67

Status

()

defect
P3
normal
RESOLVED FIXED
11 months ago
2 months ago

People

(Reporter: leplatrem, Assigned: aqadri)

Tracking

61 Branch
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

11 months ago
Running current mozilla-central (Rev 257c191e7903) I see this error when I close the browser toolbox.

```
JavaScript error: resource:///modules/aboutpages/AboutPrivateBrowsingHandler.jsm, line 27: TypeError: this.pageListener is undefined
```
Blocks: 1459204
Priority: -- → P3

Comment 1

5 months ago
I, too, see that error when running from inbound with changeset 504516:81b6f9ff742e. Let me know if there is anything I can do to help you debug!

Will
Duplicate of this bug: 1503881

Comment 3

5 months ago
I was hoping to be able to provide more information about this bug, but I can't seem to recreate it. I will keep trying and let you know if I have any success.

I think at this point we should just do the same as BrowserUsageTelemetry.jsm and add a variable that tracks if AboutPrivateBrowsingHandler.jsm has been initialized.

https://searchfox.org/mozilla-central/rev/89414a1df52d06cfc35529afb9a5a8542a6e4270/browser/modules/BrowserUsageTelemetry.jsm#375,381,403-405

Assignee: nobody → asra.qadri
Status: NEW → ASSIGNED

Hey :aqadri, I've given you access to edit any bug (please use it responsibly), so you may set checkin-needed on this one now to get your patch landed :)

Assignee

Updated

2 months ago
Keywords: checkin-needed

Comment 7

2 months ago

Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5da37483c3e2
Error this.pageListener is undefined in AboutPrivateBrowsingHandler.jsm r=johannh

Keywords: checkin-needed

Comment 8

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
You need to log in before you can comment on or make changes to this bug.