Flash Player doesn't work when I leave out the <EMBED> tag

CLOSED INVALID

Status

()

Core
Plug-ins
CLOSED INVALID
16 years ago
16 years ago

People

(Reporter: Julian Ahrens, Assigned: rubydoo123)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [need testcase][flash], URL)

(Reporter)

Description

16 years ago
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

I saw, that the <EMBED> tag is not offical part of HTML 4.01 Transitional. I
tried to remove the <EMBED> tag from a my Shockwave Flash <OBJECT>. It worked
perfect in the MSIE 6.0 but not in Mozilla 1.0 or Netscape 6.2 .

Reproducible: Always
Steps to Reproduce:
1. Embed a Macromedia Shockwave Flash Moovie
2. Don't use the <EMBED> Tag in the <OBJECT>
3. Try in IE and in Netscape or Mozilla

Actual Results:  IE shows the moovie correctly. Mozilla and Netscape show nothing.

Expected Results:  MZ should show the moovie as in IE

Comment 1

16 years ago
Tentatively reassigning to plugins.

Reporter, please attach an HTML snippet demonstrating your problem.
Assignee: adamlock → beppe
Component: Embedding: ActiveX Wrapper → Plug-ins
QA Contact: cpratt → shrir
(Assignee)

Comment 2

16 years ago
some of the contents of the embed tag would need to reside in the object tag.
So, instead of deleting the nested embed tag, use a nested object tag (presuming
the outer most object contains the activeX controls for IE.

Updated

16 years ago
Whiteboard: [need testcase][flash]

Comment 3

16 years ago
No, this is not a bug! You can't just 'remove' the embed tag and expect Mozilla
to work with the existing OBJECT tag which is probably coded for ActiveX with
some UUID. Gecko does work with the OBJECT tag, as long as you replace the
CLASSID attribute with TYPE pointing to the mime type for the pluign you'd like
to use.

-->INVALID
Please re-open if you have a testcase and do not agree.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

16 years ago
O.K. thanx, it works now
Status: RESOLVED → CLOSED
You need to log in before you can comment on or make changes to this bug.