Closed Bug 1470199 Opened 2 years ago Closed 2 years ago

Add a CVV Tooltip

Categories

(Firefox :: WebPayments UI, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 64
Tracking Status
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- fixed
firefox65 --- verified

People

(Reporter: epang, Assigned: jaws)

References

(Depends on 1 open bug)

Details

(Whiteboard: [webpayments])

Attachments

(2 files, 2 obsolete files)

Add visuals and content for the different kinds of tooltips for CVV
Will also need content from Brian
Status: NEW → ASSIGNED
Priority: P3 → P1
Flags: qe-verify-
Attached image error_screens.png (obsolete) —
Updated images and copy for error screens

Link to spec: 
https://mozilla.invisionapp.com/share/S5FXRY0D8TZ#/304878932_7-2_Checkout_-_Faliure
Attached file Icon_Assets.zip (obsolete) —
Image assets
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #8999629 - Attachment is obsolete: true
Attachment #8999630 - Attachment is obsolete: true
Status: REOPENED → ASSIGNED
Attached file CVV Hint Images
Here are the svg images for both front and back of card CVV Hints.
Let me know if there are any issues with the svgs. I've reduced them to 2 colours.
Assignee: epang → nobody
Status: ASSIGNED → NEW
Flags: qe-verify-
Priority: P1 → P3
Whiteboard: [webpayments] [ux] → [webpayments-reserve]
Flags: qe-verify+
QA Contact: hani.yacoub
Blocks: 1477118
Priority: P3 → P2
Summary: Create CVV Tooltip Image variations → Add a CVV Tooltip
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Priority: P2 → P1
Whiteboard: [webpayments-reserve] → [webpayments]
Whiteboard: [webpayments] → [webpayments-reserve]
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Duplicate of this bug: 1477118
Whiteboard: [webpayments-reserve] → [webpayments]
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d545a48c1bfd
Add a tooltip for the CVV input. r=MattN
https://hg.mozilla.org/mozilla-central/rev/d545a48c1bfd
Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
The hint on Mac OS looks a bit off please see https://imgur.com/a/GrZgm7x.
On Windows 10/7 x64 and on Ubuntu 18.04 x64 the hint looks as expected.

Should I log a new bug for this?
Flags: needinfo?(jaws)
(In reply to Hani Yacoub from comment #9)
> The hint on Mac OS looks a bit off please see https://imgur.com/a/GrZgm7x.
> On Windows 10/7 x64 and on Ubuntu 18.04 x64 the hint looks as expected.
> 
> Should I log a new bug for this?

Thanks, yes please file a new bug for this.
Flags: needinfo?(jaws)
Depends on: 1499298
No longer depends on: 1499298
Depends on: 1499298
Depends on: 1501170
I'll mark this bug as verified as fixed on Firefox Nightly 65.0a1 (2018-10-25) on Windows 10 x 64, Windows 7 x32, Mac OS X 10.13 and on Ubuntu 16.04 x64 since bug 1499298 will handle the other issues.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.