Closed Bug 1470211 Opened Last year Closed Last year

Dismissing a "Bookmarked" card that is also "Saved to Pocket" causes the saved one to disappear after saving another website to Pocket

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.3 - Aug 6
Tracking Status
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- verified

People

(Reporter: ppop, Assigned: ursula)

References

Details

Attachments

(3 files)

Attached image AS-Highlights.gif
[Affected versions]:
-Nightly Version 62.0a1, Build ID 20180621013659
-Beta Version 61.0, Build ID 20180620142108
-Firefox Version 60.0.2, Build ID 20180605171542

[Affected Platforms]:
-Windows 10 x64
-Mac 10.13.5

[Steps to reproduce]:
1. Open the browser and access a website.
2. Save the page to Pocket and Bookmark it.
3. Open a new tab and dismiss the previously bookmarked card.
4. Navigate to a different website.
5. Save the page to Pocket and Bookmark it.
6. Open a new tab and observe the highlights section.

[Expected results]:
- The section correctly displays the first webpage saved to Pocket as well as the second webpage bookmarked and saved to Pocket.

[Actual results]:
- The first Pocket saved website is no longer displayed and only the second bookmarked and Pocket saved website is.

[Notes]:
- This issue is not reproducible on Ubuntu.
- Attached a screen recording of the issue.
Iteration: --- → 63.1 - July 9
Priority: -- → P1
Assignee: nobody → usarracini
Iteration: 63.1 - July 9 → 63.2 - July 23
Iteration: 63.2 - July 23 → 63.3 - Aug 6
Duplicate of this bug: 1443154
This bug will have to land in 2 parts, one change will be made in NewTabUtils.jsm to check the open_url when processing highlights and filtering out blocked ones, and the other change will be to use the open_url to block the site. The second change will land in Activity Stream as it is part of the content code of Activity Stream
Attachment #8996426 - Flags: review?(edilee)
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/36f84f507f54830bf4c5e8db2ad16391f5857571
Fix Bug 1470211 - Dismissing a Bookmarked highlight also dismissed a
Saved To Pocket highlight of the same content - Part 2

https://github.com/mozilla/activity-stream/commit/dfd87e2b4ddf004b00009f92eb814f826c2be549
Merge pull request #4275 from sarracini/bug_1470211

Fix Bug 1470211 - Dismissing a Bookmarked highlight also dismissed a Saved To Pocket highlight of the same content - Part 2
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Not resolved just yet, Github robot!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8996426 [details]
Bug 1470211 - Dismissing a Bookmarked highlight also dismisses a Saved To Pocket highlight of the same content - Part 1

https://reviewboard.mozilla.org/r/260524/#review267624

We probably want to add to the xpcshell test to make sure this doesn't regress.

::: toolkit/modules/NewTabUtils.jsm:820
(Diff revision 2)
>      // Filter out blocked if necessary
>      if (!aOptions.ignoreBlocked) {
> -      aLinks = aLinks.filter(link => !BlockedLinks.isBlocked(link));
> +      aLinks = aLinks.filter(link => {
> +        // If it is a pocket link, check the open_url field, since that is what we blocked originally
> +        if (link.pocket_id) return !BlockedLinks.isBlocked({url: link.open_url});
> +        return !BlockedLinks.isBlocked(link);

nit: you could…

filter(link => !BlockedLinks.isBlocked(link.pocket_id ? {url: link.open_url} : link));
Comment on attachment 8996426 [details]
Bug 1470211 - Dismissing a Bookmarked highlight also dismisses a Saved To Pocket highlight of the same content - Part 1

https://reviewboard.mozilla.org/r/260526/#review267630
Attachment #8996426 - Flags: review?(edilee) → review+
Pushed by usarracini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/675e65d26f41
Dismissing a Bookmarked highlight also dismisses a Saved To Pocket highlight of the same content - Part 1 r=Mardak
Blocks: 1479836
https://hg.mozilla.org/mozilla-central/rev/675e65d26f41
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Is this something we plan to let ride the trains?
Flags: needinfo?(usarracini)
Yes, it will just ride the trains. No need to uplift :)
Flags: needinfo?(usarracini)
I have reproduced this bug with Nightly 62.0a1 (2018-06-21) with Windows 10, 64 Bit!
This bug's fix is verified with latest Nightly!

Build ID 	20180827100129
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
QA Whiteboard: [bugday-20180829]
I have verified that this issue is no longer reproducible on Windows 10 X64, Mac 10.13.3 and Ubuntu 16.04 using the latest "Firefox Nightly" (Version 63.0a1, Build ID 20180903220141).
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.