Closed Bug 1470299 Opened 3 years ago Closed 3 years ago

In Nexus 4 API 23, m.yelp.de progress stuck at 25%

Categories

(GeckoView :: General, defect, P1)

defect

Tracking

(firefox-esr52 wontfix, firefox-esr60 wontfix, firefox61 wontfix, firefox62+ fixed, firefox63 fixed)

RESOLVED FIXED
mozilla63
Tracking Status
firefox-esr52 --- wontfix
firefox-esr60 --- wontfix
firefox61 --- wontfix
firefox62 + fixed
firefox63 --- fixed

People

(Reporter: njpark, Assigned: esawin)

References

Details

(Whiteboard: [geckoview:klar:p1] [qf:p1])

On latest klar geckoview, going to m.yelp.com on Nexus 4 5.1 device causes the site to continuously reload.  This is different from previous behavior, where the progressbar was not completing/disappearing.
No-Jun says the site loads correctly on his Pixel 2. The site loads correctly for me on my Moto G5 Plus.

It sounds like this is a recent regression.
Priority: -- → P1
Whiteboard: [geckoview] [qf:p1]
On today's Klar Geckoview, instead of reloading, it exhibits https://bugzilla.mozilla.org/show_bug.cgi?id=1454477#c3 (progressbar stuck at 25%)
Chris, are we shipping Klar/Geckoview in 62 or 63?
Flags: needinfo?(cpeterson)
Looks like the plan as of June 20 is to ship in 62.
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #4)
> Looks like the plan as of June 20 is to ship in 62.

Yes. We're aiming to ship GeckoView 62 in Focus (7.0 in September). We'll find an owner for this P1 bug in GeckoView triage tomorrow.
Flags: needinfo?(cpeterson)
Assignee: nobody → esawin
Summary: In Nexus 4 API 23, m.yelp.de site is loaded repeatedly on Klar Geckoview → In Nexus 4 API 23, m.yelp.de progress stuck at 25%
I was able to reproduce this on a Nexus 4 on cnn.com. I tried m.yelp.de and it seemed fine. Looks like Gecko is just not sending us a message via the progress listener. Don't know why yet. Investigating further...
Assignee: snorp → esawin
[geckoview:klar:p1] because this is a Focus+GV blocker.
Assignee: esawin → nobody
Whiteboard: [geckoview] [qf:p1] → [geckoview:klar:p1] [qf:p1]
Assignee: nobody → esawin
Depends on: 1437988
With bug 1437988 landed, can we move away from using onPageStop as a signal for the progress bar on Focus, Emily?

The progress bar is a visual indicator for the visual page load progression, it should probably be based entirely on the value emitted by onProgressChanged.

On the GV side, we will continue investigating why on some page-device combinations onPageStop is not fired, but generally this issue not directly affecting the visual page load progress.
Flags: needinfo?(ekager)
I think Emily might be on PTO, Sebastian, can you look at comment 8?
Flags: needinfo?(s.kaspari)
Merged a fix into Focus master that uses 100% progress to stop the progress bar.
Flags: needinfo?(ekager)
Flags: needinfo?(s.kaspari)
No-Jun, can you please verify that this issue is fixed on Focus' nightly channel?
Flags: needinfo?(npark)
Just verified on nexus 4 that with Geckoview the progressbar progresses normally, and disappears.  Can't reproduce the original issue anymore after multiple tries.
Flags: needinfo?(npark)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Product: Firefox for Android → GeckoView
Keywords: regression
Target Milestone: Firefox 63 → mozilla63
You need to log in before you can comment on or make changes to this bug.