Crash in cookies dialog clicking on "View Stored Cookies"

VERIFIED DUPLICATE of bug 21877

Status

()

Core
Layout
P3
critical
VERIFIED DUPLICATE of bug 21877
19 years ago
19 years ago

People

(Reporter: Alec Flett, Assigned: vidur (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
In the wallet dialog, I clicked "View sites that cannot store cookies" then
clicked back on

stack trace:
(gdb) where 10
#0  0x40c70c55 in nsGenericElement::HandleDOMEvent (this=0x8d457a8,
    aPresContext=@0x8ba5a60, aEvent=0xbfffd3cc, aDOMEvent=0x0, aFlags=1,
    aEventStatus=@0xbfffd32c) at nsGenericElement.cpp:776
#1  0x40b2925e in nsHTMLAnchorElement::HandleDOMEvent (this=0x8d45790,
    aPresContext=@0x8ba5a60, aEvent=0xbfffd3cc, aDOMEvent=0x0, aFlags=1,
    aEventStatus=@0xbfffd32c) at nsHTMLAnchorElement.cpp:289
#2  0x40add5d6 in nsEventStateManager::SendFocusBlur (this=0x8d4a128,
    aContent=0x8d4a054) at nsEventStateManager.cpp:1447
#3  0x40add316 in nsEventStateManager::SetContentState (this=0x8d4a128,
    aContent=0x8d4a054, aState=3) at nsEventStateManager.cpp:1336
#4  0x40b29365 in nsHTMLAnchorElement::HandleDOMEvent (this=0x8d4a048,
    aPresContext=@0x8ba5a60, aEvent=0xbfffd99c, aDOMEvent=0xbfffd630,
    aFlags=2, aEventStatus=@0xbfffd8a8) at nsHTMLAnchorElement.cpp:307
#5  0x40c70cf5 in nsGenericElement::HandleDOMEvent (this=0x8d47164,
    aPresContext=@0x8ba5a60, aEvent=0xbfffd99c, aDOMEvent=0xbfffd630,
    aFlags=2, aEventStatus=@0xbfffd8a8) at nsGenericElement.cpp:796
#6  0x40b3f2f7 in nsHTMLFontElement::HandleDOMEvent (this=0x8d47150,
    aPresContext=@0x8ba5a60, aEvent=0xbfffd99c, aDOMEvent=0xbfffd630,
    aFlags=2, aEventStatus=@0xbfffd8a8) at nsHTMLFontElement.cpp:367
#7  0x40c6eef1 in nsGenericDOMDataNode::HandleDOMEvent (this=0x8d47210,
    aPresContext=@0x8ba5a60, aEvent=0xbfffd99c, aDOMEvent=0x0, aFlags=1,
    aEventStatus=@0xbfffd8a8) at nsGenericDOMDataNode.cpp:747
#8  0x40c8f127 in nsTextNode::HandleDOMEvent (this=0x8d471f8,
    aPresContext=@0x8ba5a60, aEvent=0xbfffd99c, aDOMEvent=0x0, aFlags=1,
    aEventStatus=@0xbfffd8a8) at nsTextNode.cpp:200
#9  0x40b11cfb in PresShell::HandleEvent (this=0x8c17860, aView=0x8c212b0,
    aEvent=0xbfffd99c, aEventStatus=@0xbfffd8a8) at nsPresShell.cpp:2077
(More stack frames follow...)
(gdb) frame 0
#0  0x40c70c55 in nsGenericElement::HandleDOMEvent (this=0x8d457a8,
    aPresContext=@0x8ba5a60, aEvent=0xbfffd3cc, aDOMEvent=0x0, aFlags=1,
    aEventStatus=@0xbfffd32c) at nsGenericElement.cpp:776
776	        mParent->HandleDOMEvent(aPresContext, aEvent, aDOMEvent,
NS_EVENT_FLAG_CAPTURE, aEventStatus);
(gdb) list
771	      //mDOMSlots->mCapturer->HandleDOMEvent(aPresContext, aEvent,
aDOMEvent, NS_EVENT_FLAG_CAPTURE, aEventStatus);
772	    //} else {
773	      // Node capturing stage
774	      if (mParent) {
775	        // Pass off to our parent.
776	        mParent->HandleDOMEvent(aPresContext, aEvent, aDOMEvent,
NS_EVENT_FLAG_CAPTURE, aEventStatus);
777	      } else {
778	        //Initiate capturing phase.  Special case first call to
document779	        if (nsnull != mDocument) {
780	          mDocument->HandleDOMEvent(aPresContext, aEvent, aDOMEvent,
NS_EVENT_FLAG_CAPTURE, aEventStatus);
(gdb) print mParent
$1 = (nsIContent *) 0x8bbe1c0
(gdb) print aPresContext
$2 = (nsIPresContext &) @0x8ba5a60: {<nsISupports> = {
      _vptr. = 0x40d39ea0 <GalleyContext virtual table>}, }
(gdb) print aEvent
$3 = (nsEvent *) 0xbfffd3cc
(gdb) print aDOMEvent
$4 = (nsIDOMEvent **) 0xbfffd158
(gdb) print aEventStatus
$5 = (nsEventStatus &) @0xbfffd32c: nsEventStatus_eIgnore
(gdb) print this
$6 = (nsGenericElement *) 0x8d457a8

I also got an assertion from necko, just before the crash:
Error: "Failed to create/get a transport!" at file nsHTTPChannel.cpp, line 632
Break: at file nsHTTPChannel.cpp, line 632

I have a feeling there's something bogus with that link.
(Reporter)

Updated

19 years ago
Summary: Crash in wallet dialog → Crash in cookies dialog clicking on "View Stored Cookies"
(Reporter)

Comment 1

19 years ago
oops, forgot to finish that first sentence:
..clicked back on View stored cookies

This is under Edit->Wallet->Display Cookies
(Reporter)

Comment 2

19 years ago
I get the same crash in the "Display Signons" dialog, when on click on the third
link at the top of the dialog.

Comment 3

19 years ago
Is this a linux-only bug or does this occur on the other platforms as well?

Updated

19 years ago
Assignee: troy → vidur

Comment 4

19 years ago
Vidur, looks DOM related

Comment 5

19 years ago
In order to avoid this crash, the cookie viewer and the signon viewer (both of
which demonstrated this bug) were scrapped and completely new viewers checked
in.  So this bug is no longer demonstrable from those dialogs.  However, you can
still see the bug by creating a page with the following content and then
clicking on the "click here" message.

<HTML>
  <HEAD>
    <SCRIPT>
      function loadCookies(){
        top.frames[0].document.open();
        top.frames[0].document.write(
          "<BODY>" +
            "<A ONCLICK=top.loadPermissions(); HREF= > Click here </A>" +
          "</BODY>"
        );
        top.frames[0].document.close();
      }
      function loadPermissions(){
        top.frames[0].document.open();
        top.frames[0].document.close();
      }
    </SCRIPT>
  </HEAD>
  <FRAMESET ROWS = 25,* onLoad=loadCookies()>
    <FRAME SRC=about:blank>
    <FRAME SRC=about:blank>
  </FRAMESET>
  <NOFRAMES>
    <BODY> <P> </BODY>
  </NOFRAMES>
</HTML>

Updated

19 years ago
Severity: normal → critical
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 6

19 years ago
Seems to work for me. Several fixes to deal with event firing for frames that
have already been deleted have gone in since the bug was reported. Maybe it was
fixed by one of them?

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 7

19 years ago
Reopening.  It does not work for me.  I just tried it with last nights build and
got the same stack trace.

Were you testing with the sample html shown above?  If you test with the cookie
viewer as per the original description, that will work fine because we have
completely rewritten the viewer since this bug was filed.
(Assignee)

Comment 8

19 years ago
In an attempt to get my bug list in order again, marking all the bugs I have
currently as ASSIGNED.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 9

19 years ago
*** This bug has been marked as a duplicate of 21877 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
Agreed. Marking as verified dup of 21877.
You need to log in before you can comment on or make changes to this bug.