Closed Bug 1470437 Opened 2 years ago Closed 2 years ago

Assertion failure: ret, at /builds/worker/workspace/build/src/gfx/webrender_bindings/Moz2DImageRenderer.cpp:324

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1466613
Tracking Status
firefox62 --- affected

People

(Reporter: truber, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: assertion, testcase)

Attachments

(1 file)

Attached file testcase.html
The attached testcase causes an assertion in m-c 20180622-6b6f3f6ecf14 with pref("gfx.webrender.all", true)

Assertion failure: ret, at /builds/worker/workspace/build/src/gfx/webrender_bindings/Moz2DImageRenderer.cpp:324
#0: wr_moz2d_render_cb
        at mfbt/RangedPtr.h:281
#1: _..panic..AssertUnwindSafe1101u20..ops..function..FnOnce1101LP1101RP1101GT1101GT$::call_once
        at gfx/webrender_bindings/src/moz2d_renderer.rs:437
#2: std::panicking::try::do_call
        at src/libstd/panicking.rs:480
#3: panic_abort::__rust_maybe_catch_panic
        at src/libpanic_abort/lib.rs:38
#4: _..job..HeapJob1101u20..job..Job$::execute
        at src/libstd/panicking.rs:459
#5: rayon_core::registry::WorkerThread::wait_until_cold
        at third_party/rust/rayon-core/src/job.rs:60
#6: rayon_core::registry::main_loop
        at third_party/rust/rayon-core/src/registry.rs:543
#7: std::panicking::try::do_call
        at src/libstd/thread/mod.rs:406
#8: panic_abort::__rust_maybe_catch_panic
        at src/libpanic_abort/lib.rs:38
#9: _..boxed..FnBox1101GT$::call_box
        at src/libstd/panicking.rs:459
#10: std::sys_common::thread::start_thread
        at src/liballoc/boxed.rs:825
#11: std::sys::unix::thread::Thread::new::thread_start
        at src/libstd/sys/unix/thread.rs:90
Flags: in-testsuite?
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1466613
Blocks: wr-fuzz
You need to log in before you can comment on or make changes to this bug.