Closed Bug 14705 Opened 21 years ago Closed 20 years ago

Table model concerning the element TR

Categories

(Core :: Layout: Tables, defect, P3)

x86
Other
defect

Tracking

()

VERIFIED INVALID

People

(Reporter: tapio.markula, Assigned: karnaze)

References

()

Details

(Keywords: css2, Whiteboard: ?? it is unclear what the bug actually is here, was awaiting simplified test case from reporter)

http://www.nic.fi/~tapio1/Teaching/Model25a.html

Doesn't take all borders and backgroundcolors.


table.separate {border-collapse: separate; border-spacing: 5pt;}

/* table.separate td  {border-collapse: separate; border-spacing: 15pt;border: 10px solid green;} */
/*
table.collapse {border-collapse: collapse;border-spacing: 15pt;border: 10px solid maroon;}
 table.collapse td {border-collapse: collapse;border-spacing: 15pt;border: 10px solid green;} */

tr:first-child  {background-color: white; border-top: solid black 3px; } /* border doesn't work */
tr {background-color: aqua; color:black;border:yellow 3px solid; }/* border doesn't work */

table.aqua         { border-collapse: collapse;
                   border: 5px solid yellow; background-color:aqua}

*#col1  { border: 3px solid black;}
*#col2  { border: 3px solid red;}
*#col3  { border: 3px solid olive;}

*#row1 {border: 3px green solid; background-color:aqua;}
*#row2 {border: 3px solid green; background-color:white;}
*#row3 {border: 3px solid blue; background-color:lime;}
*#row4 {border: 3px solid blue; background-color:yellow;}
*#row5 {border: 3px solid blue; background-color:green;} /* background-color doesn't work*/
Assignee: troy → karnaze
Component: Layout → HTMLTables
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → INVALID
I think this bug is invalid. The background color from the style rules with the
universal selectors is used. The tr:first-child does not take precedence over
the style rules that meet all table cells with a certain id. The border style
from the style rule that selects via an id and inheritance has a greater
specifity than the tr directly, so the border style specified there should take
effect.

There are many problems with collapsing tables/ borders, so it is possible that
I missed something; if so, please reopen this one, or file a new one (remember,
one bug per issue!). Thanks.
Status: RESOLVED → VERIFIED
Based on the last comment, marking as verified invalid.
Status: VERIFIED → REOPENED
These properties
table.separate {border-collapse: separate; border-spacing: 5pt;}
tr:first-child  {background-color: white; border-top: solid black 3px; }
tr {background-color: aqua; color:black;border:yellow 3px solid; }

Concerns this table in the BODY:
<table class="separate">
	<tr>
		<td>Tämä on erottavan (<code>border-collapse: separate;</code>) taulukkomallin solu.</td>
		<td>Tämä on erottavan taulukkomallin solu.</td>
	</tr>
	<tr>
		<td>Tämä on erottavan taulukkomallin solu.</td>
		<td>Tämä on erottavan taulukkomallin solu.</td>
	</tr>
</table>
In my mind table rows should have borders, but they don't have any borders
- but the background-color is according to these rules and Mozilla displays
only these properties:
tr:first-child  {background-color: white}
tr {background-color: aqua;; color:black;}
not these:
tr:first-child  {border-top: solid black 3px; }
tr {border:yellow 3px solid; }


http://www.nic.fi/~tapio1/Opetus/Model25a.html
or
http://www.nic.fi/~tapio1/Teaching/Model25a.html
Resolution: INVALID → ---
Clearing INVALID resolution due to reopen of this bug.
QA Contact: petersen → chrisd
In the separated border model, table rows do not have borders.  Only cells and
tables do.  Is that the bug here?
Summary: CSS2 Table model concerning the element TR → {css2} Table model concerning the element TR
Whiteboard: ?? it is unclear what the bug actually is here, awaiting simplified test case from reporter
Status: REOPENED → ASSIGNED
Target Milestone: M14
Tapio: Could you please explain exactly what the bug is here?
Keywords: css2
Migrating from {css2} to css2 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
Target Milestone: M14 → M16
Summary: {css2} Table model concerning the element TR → Table model concerning the element TR
No response from reporter, and it is unclear what the problem is, so marking
INVALID.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → INVALID
Whiteboard: ?? it is unclear what the bug actually is here, awaiting simplified test case from reporter → ?? it is unclear what the bug actually is here, was awaiting simplified test case from reporter
Adding 'verifyme' keyword
Keywords: verifyme
Verifying invalid-no response from reporter
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.