throbber stays on after clicking link to FTP site with permissions error

VERIFIED WORKSFORME

Status

()

Core
Networking: FTP
--
minor
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Tony Houghton, Assigned: bbaetz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
If you go to the test URL (hurry, in case they fix the problem with the FTP
site!) and click on the first tutorial link (Martin Bernreuther's Introduction
to              wxWindows), a PDF on an FTP server, there's a permissions
problem, and the spinner/throbber stays on without ever being switched off until
stop is clicked or loading of a new page is completed. (Mozilla Debian Package
1.0rc2-2).

Updated

16 years ago
Summary: Spinner stays on after clicking link to FTP site with permissions error → throbber stays on after clicking link to FTP site with permissions error
(Assignee)

Comment 1

16 years ago
confirming, -> ftp
Assignee: Matti → bbaetz
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking: FTP
Ever confirmed: true
QA Contact: imajes-qa → benc
(Reporter)

Comment 2

16 years ago
Created attachment 88925 [details]
Javascript with reference to non-existent image

Viewing this offline sometimes (always in Galeon) makes the throbber stay on.
(Reporter)

Comment 3

16 years ago
This also sometimes happens when viewing sites with Javascript referring to
non-existent images. I can't get Mozilla to do it consistently, but Galeon does
it every time such a page is viewed *offline* (ie file:// not http:// etc). See
attachment for example.
(Assignee)

Comment 4

16 years ago
I have no time to work on mozilla at the moment, so dougt is taking over FTP

open ftp bugs -> him
Assignee: bbaetz → dougt

Comment 5

16 years ago
javascript for a triaging.
Assignee: dougt → rogerl
Component: Networking: FTP → JavaScript Engine
QA Contact: benc → pschwartau

Comment 6

16 years ago
reporter:

please try a newer build. This sounds like it is actually fixed in bug 162326.

If so, send the bug back to FTP, and use "reassign bug to owner of selected
component."

Comment 7

16 years ago
I agree with Ben. At any rate, both the ftp site and Tony's
testcase in Comment #2 are WORKSFORME using a current Mozilla build.

Because of the similarity with bug 162326, let me reassign back
to Networking: FTP, but I will resolve this as WORKSFORME.
Assignee: rogerl → bbaetz
Component: JavaScript Engine → Networking: FTP
QA Contact: pschwartau → benc

Comment 8

16 years ago
Resolving as WORKSFORME.  Both the ftp site and Tony's testcase
in Comment #2 work fine for me using current Mozilla builds on 
WinNT, Linux. The throbber does not stay running no matter what 
I do.

Of course, when accessing the ftp site the throbber runs until
the Acrobat PDF file is loaded, which can take 10 - 20 seconds.
But once it's loaded, the throbber stops. 

This may not be the permissions problem Tony first reported,
however. But again, the testcase in Comment #2 works fine, too.

Tony: can you confirm this with an up-to-date build? If everything
is OK for you, too, could you mark this bug "Verified"? Otherwise,
you can reopen the bug; thanks -

Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 9

16 years ago
VERIFIED: Mozilla 1.1, Mac OS X, Linux.
Throbber does not run anymore after the error messages are dismissed. Still
happens in Windows, see bug 162326.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.