Implement ability to send a selection of tabs

VERIFIED FIXED in Firefox 64

Status

()

enhancement
P1
normal
VERIFIED FIXED
Last year
8 months ago

People

(Reporter: jaws, Assigned: ablayelyfondou, Mentored)

Tracking

(Blocks 1 bug)

Trunk
Firefox 64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox62 wontfix, firefox63 wontfix, firefox64 verified, firefox65 verified)

Details

(Whiteboard: [blocking-multiselect-tabs])

Attachments

(1 attachment, 1 obsolete attachment)

+++ This bug was initially created as a clone of Bug #1458061 +++

When a group of tabs are selected, right-clicking on any tab in the selection should:
 1. Provide a context menu option of "Send selected Tabs to Device".
 1. The "Send Tab to Device" option will be hidden.
Assignee: nobody → ablayelyfondou
Status: NEW → ASSIGNED
Whiteboard: [blocking-multiselect-tabs]
Priority: P3 → P1
Comment on attachment 8999275 [details]
Bug 1470555 - Implement ability to send a selection of tabs. r?jaws

Francesco Lodolo [:flod] has approved the revision.
Attachment #8999275 - Flags: review+
Comment on attachment 8999275 [details]
Bug 1470555 - Implement ability to send a selection of tabs. r?jaws

Jared Wein [:jaws] (please needinfo? me) has approved the revision.
Attachment #8999275 - Flags: review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bc1e9abe3747
Implement ability to send a selection of tabs. r=flod,jaws
https://hg.mozilla.org/mozilla-central/rev/bc1e9abe3747
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Depends on: 1489754
Depends on: 1489834
Attachment #9008587 - Attachment is obsolete: true
Depends on: 1492702
I have reproduced  this bug with Nightly 62.0a1 (2018-06-22) on Windows 7, 64 Bit!
This bug's fix is verified with latest Nightly!

Build ID 	20180921100113
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0
QA Whiteboard: [bugday-20180919]
I selected 4 tabs and Send 4 Tabs To Device submenu and select "Firefox on iPhone". 
On my iPhone I am getting a message to download a firefox. 
I don't see any tabs which are sent.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Damira Akh from comment #8)
> I selected 4 tabs and Send 4 Tabs To Device submenu and select "Firefox on
> iPhone". 
> On my iPhone I am getting a message to download a firefox. 
> I don't see any tabs which are sent.

Please keep this bug marked as resolved-fixed since patches have landed. If you cannot verify the bug then please file a new one. We usually only reopen a bug if the patch that landed got backed out.

I also see the same result as you. I am filing a new bug that will block this bug and I will include a patch there to fix it as well as include a test.
Status: REOPENED → RESOLVED
Closed: 11 months ago10 months ago
Resolution: --- → FIXED
Depends on: 1496309
Hello Jared,

So we have verified this issue on the latest Nightly 65.0a1 and the latest beta 64.0b8 on Windows 10x64, Ubuntu 16.04x64 and macOS 10.13 and we have the following mentions:

-Sending tabs works as expected on all the above specified platforms with the mention that sent pinned tabs will be received as unpinned.

Should I file a different bug for that behavior and close this one?
Flags: needinfo?(jaws)
Maintaining "pinned" state isn't something that we have supported before, and sending tabs doesn't try to maintain position or order of tabs either. Most likely if you filed a bug for it the bug would get resolved as 'wontfix' so I think you can pass on filing the bug. Thanks for asking :)
Flags: needinfo?(jaws)
Status: RESOLVED → VERIFIED
This patch (and its follow-up) introduced even more technical debt on the implementation of the Send Tab UI.
I am not pointing any fingers, however I would like to be asked for review (or at least get CCed) next time a change of this magnitude is made to this module.
You need to log in before you can comment on or make changes to this bug.