F6 doesn't switch to main screen when displaying a file

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: hugovanwoerkomqt, Assigned: aaronlev)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When you have the Sidebar up the F6 normally switches the "active cursor"
between sidebar, navigation bar and screen. So when you want to hit a page key
you need to know where you are because the wrong things will scroll.
But when showing a file (file:///) the F6 key only switches between sidebar and
nav bar, never "landing" on the screen so you can use the page keys.
You have to dig your mouse out of your pocket and use it. Select some text and
then can you use the scroll keys.

Trunk Build 5/23
(Reporter)

Comment 1

17 years ago
Same in Mozilla 1.0 Release Candidate 3 
-> Keyboard Navigation
Assignee: Matti → aaronl
Component: Browser-General → Keyboard Navigation
QA Contact: imajes-qa → sairuh

Comment 3

16 years ago
Works for me.  I am using

BUILD: 2002060308
PLATFORM: PC
OS: Linux 2.4.18 RedHat 7.2 (XFree86 4.1.0)

Tried steps as outlined by reporter.

Recreated described conditions: 
While URL in location bar is pointing to a file (file:///somefile)


Actions taken to recreate bug:
Was able to switch from location bar, Sidebar, and "screen" (or browser window)
using the F6 function key.  Also, was able to scroll all three components
contents when in focus.

(Reporter)

Comment 4

16 years ago
Right, I now can too.

Comment 5

16 years ago
Since reproducing this bug seems unsuccessful, I'm marking this uncomfirmed bug
as WORKSFORME.  Hugo, please feel free to reopen this bug if reproducible in a
current build.  Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.