Status

enhancement
RESOLVED FIXED
Last year
2 months ago

People

(Reporter: jlorenzo, Assigned: jlorenzo)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox63 fixed)

Details

Attachments

(8 attachments)

58 bytes, text/x-github-pull-request
mtabara
: review+
jlorenzo
: checked-in+
Details | Review
54 bytes, text/x-github-pull-request
mtabara
: review+
jlorenzo
: checked-in+
Details | Review
46 bytes, text/x-phabricator-request
jchen
: review+
Details | Review
46 bytes, text/x-phabricator-request
mtabara
: review+
Details | Review
55 bytes, text/x-github-pull-request
mtabara
: review+
Details | Review
58 bytes, text/x-github-pull-request
jlorenzo
: review+
jlorenzo
: checked-in+
Details | Review
55 bytes, text/x-github-pull-request
jlorenzo
: review+
Details | Review
46 bytes, text/x-phabricator-request
mtabara
: review+
Details | Review
In bug 1433198, we want to upload geckoview artifacts on a maven-like repo. This kind of repo can be hosted on S3 (bug 1464807). Bug 1470937 takes care of the bucket set up. Let's make beetmover upload to this new bucket.
Work on PR is still ongoing. We decided to go with zip files that we extract on beetmover (bug 1433198 comment 25). This requires some safety checks that I implemented in the PR. Some of the checks are still missing tests. I also should ensure the integration with move_beets() works fine.
Comment on attachment 8995117 [details]
Bug 1470942 - part 1: Craft zip archive of maven artifacts r=jchen

Jim Chen [:jchen] [:darchons] has approved the revision.

https://phabricator.services.mozilla.com/D2420
Attachment #8995117 - Flags: review+
Comment on attachment 8987559 [details] [review]
[beetmoverscript] PR: Support maven on S3

Comments in the PR.
Attachment #8987559 - Flags: review?(mtabara) → review+
Comment on attachment 8995118 [details]
Bug 1470942 - part 2: Upload geckoview to maven repository via beetmover r=mtabara

Mihai Tabara [:mtabara]⌚️GMT has approved the revision.

https://phabricator.services.mozilla.com/D2421
Attachment #8995118 - Flags: review+
Comment on attachment 8995118 [details]
Bug 1470942 - part 2: Upload geckoview to maven repository via beetmover r=mtabara

r+ looks good, let's test more on maple to cover all cases.
Comment on attachment 8995118 [details]
Bug 1470942 - part 2: Upload geckoview to maven repository via beetmover r=mtabara

Removing the r? just to make sure Phab doesn't land this accidentaly or something.
Attachment #8995118 - Flags: review+
Attachment #8994888 - Flags: review?(mtabara) → review+
Comment on attachment 8994888 [details] [review]
[build/puppet] Bug 1470942 - Add Maven-like buckets to beetmover

Landed on master at https://github.com/mozilla-releng/build-puppet/commit/021b2ba463a15d631cbba4efc183ef4396d93551
Firefox 62.0b17 didn't have any regression: https://tools.taskcluster.net/task-group-inspector/#/PJrZEHImSmOhZAznyA3dZQ
Attachment #8994888 - Attachment description: [build/puppet] part 1: Add Releng's testing Maven-like bucket → [build/puppet] Bug 1470942 - Add Maven-like buckets to beetmover
Attachment #8994888 - Flags: checked-in+
Comment on attachment 8995118 [details]
Bug 1470942 - part 2: Upload geckoview to maven repository via beetmover r=mtabara

Mihai Tabara [:mtabara]⌚️GMT has approved the revision.
Attachment #8995118 - Flags: review+
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/056aaefaffac
part 1: Craft zip archive of maven artifacts r=jchen
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/237d45421fb5
part 2: Upload geckoview to maven repository via beetmover r=mtabara
Today's nightly decision task failed because it was missing a scope[1]. I added 
> project:releng:beetmover:action:push-to-maven
> project:releng:beetmover:bucket:maven-production
to [2]

I need to update[3] to let have this run on beta + release. Reopening until it is.



[1] https://tools.taskcluster.net/groups/bJfgiaOzSmqXZRsm9536sg/tasks/bJfgiaOzSmqXZRsm9536sg/runs/1/logs/public%2Flogs%2Flive_backing.log#L2980
[2] https://tools.taskcluster.net/auth/scopes/project%3Areleng%3Abeetmover%3Abucket%3Anightly/role:project%3Areleng%3Anightly%3Alevel-3%3A*
[3] https://hg.mozilla.org/build/ci-configuration/file/352812a6c1af/projects.yml#l177
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #9001672 - Flags: review?(mtabara) → review+
Comment on attachment 9002457 [details]
Bug 1470942 - part 3: Make beetmover-geckoview tier-2 r=mtabara

Mihai Tabara [:mtabara]⌚️GMT has approved the revision.
Attachment #9002457 - Flags: review+
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b8918cd29dde
part 3: Make beetmover-geckoview tier-2 r=mtabara
We've had geckoview uploaded on https://maven.mozilla.org since Aug 17th. It's now used by android-components[2]. Let's mark this bug as resolved then.

Sebastian told me they would like to have 62 being on maven.mozilla.org in case Focus ships with it. They'd like to it after bug 1484932 is done, though. Moreover, there is no date set for Focus+Geckoview. Therefore we agreed on not shipping 62 yet and wait for the need to come. Worst case scenario, we still can use TC artifacts to fetch 62.

[1] https://maven.mozilla.org/?prefix=maven2/org/mozilla/geckoview-nightly-x86/63.0.20180817114923/ https://maven.mozilla.org/?prefix=maven2/org/mozilla/geckoview-nightly-armeabi-v7a/63.0.20180817114923/ and https://maven.mozilla.org/?prefix=maven2/org/mozilla/geckoview-nightly-arm64-v8a/63.0.20180817114923/
[2] https://github.com/mozilla-mobile/android-components/pull/635
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Keywords: leave-open
Resolution: --- → FIXED
For the record, I just added the scopes:

* project:releng:beetmover:action:push-to-maven
* project:releng:beetmover:bucket:maven-production

to https://tools.taskcluster.net/auth/roles/moz-tree%3Alevel%3A3%3Agecko

Scopes for nightly were added in comment 20
Blocks: 1484932
No longer depends on: 1484932
You need to log in before you can comment on or make changes to this bug.