Crash starting up XML demo

VERIFIED FIXED

Status

()

Core
Networking
P1
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: Chris Fuchs, Assigned: vidur (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
I read Angus's message about Vidur's XML demo, so I pulled a raptor tree this
morning (around 11am) and built it to try the demo.  XPViewer.exe crashes as
soon as this URL is typed, if I'm running it standalone.  When I'm running in
the debugger, it doesn't crash, but it looks like there are some free memory
reads/writes... I hit a breakpoint with this stack:

nsDebug::PreCondition(char * 0x0171105c, char * 0x01711044, char * 0x01711014,
int 1450) line 75 + 13 bytes
nsDocumentBindInfo::OnDataAvailable(nsDocumentBindInfo * const 0x01314bc0,
nsIURL * 0x01315230, nsIInputStream * 0x0124f920, int 32) line 1450 + 39 bytes
OnDataAvailableProxyEvent::HandleEvent(OnDataAvailableProxyEvent * const
0x01250a60) line 606 + 45 bytes
StreamListenerProxyEvent::HandlePLEvent(PLEvent * 0x01250a64) line 452 + 12
bytes
PL_HandleEvent(PLEvent * 0x01250a64) line 408 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x011f95d0) line 370 + 9 bytes
_md_EventReceiverProc(void * 0x029804c2, unsigned int 49321, unsigned int 0,
long 18847184) line 701 + 9 bytes
USER32! 77e71260()
011f95d0()

(Marking as a netlib bug, but that's just a guess.)
(Assignee)

Updated

19 years ago
Assignee: valeski → vidur
(Assignee)

Comment 1

19 years ago
It's a problem with the XPViewer not setting up the registry correctly.
Well...maybe I should have made the same changes to the XPViewer that I did to
the regular viewer. Judson's obviously the wrong person for this bug, so I'll
take it for myself.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
Fixed.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
Layout is broken on Linux (2nd table column is blank, and page background is
grey), but I'm marking this as Verified/Fixed, since it no longer crashes.

[Checked on 2.1.99 Mac OS/Win32 builds, and 1.29.99 Linux builds, using Viewer on
all platforms.]

Comment 4

19 years ago
Changing all Networking Library/Browser bugs to Networking-Core component for
Browser.

Occasionally, Bugzilla will burp and cause Verified bugs to reopen when I do
this in a bulk change.  If this happens, I will fix. ;-)

Comment 5

18 years ago
Bulk move of all Networking-Core (to be deleted component) bugs to new
Networking component.
You need to log in before you can comment on or make changes to this bug.