Closed Bug 1471106 Opened 4 years ago Closed 4 years ago

Intermittent dom/animation/test/mozilla/test_restyles.html | Outline offset animation running on the main-thread on invisible element should be throttled - got 1, expected +0

Categories

(Core :: DOM: Animation, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: hiro)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: nerli [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=184786093&repo=mozilla-central

https://queue.taskcluster.net/v1/task/XWlSj0TgT9aIsXm8IdFDPA/runs/0/artifacts/public/logs/live_backing.log

20:41:23     INFO -  135 INFO TEST-PASS | dom/animation/test/mozilla/test_restyles.html | Visibility animation running on the main-thread on in-view element should not be throttled
20:41:23     INFO -  136 INFO AddTask.js | Leaving test restyling_visibility_animations_on_in_view_element
20:41:23     INFO -  137 INFO AddTask.js | Entering test restyling_outline_offset_animations_on_invisible_element
20:41:23     INFO -  Buffered messages finished
20:41:23    ERROR -  138 INFO TEST-UNEXPECTED-FAIL | dom/animation/test/mozilla/test_restyles.html | Outline offset animation running on the main-thread on invisible element should be throttled - got 1, expected +0
20:41:23     INFO -      SimpleTest.is@SimpleTest/SimpleTest.js:312:5
20:41:23     INFO -      restyling_outline_offset_animations_on_invisible_element@dom/animation/test/mozilla/file_restyles.html:1753:5
20:41:23     INFO -      async*add_task/</<@SimpleTest/AddTask.js:57:34
20:41:23     INFO -      async*add_task/<@SimpleTest/AddTask.js:31:10
20:41:23     INFO -      setTimeout handler*add_task@SimpleTest/AddTask.js:30:7
20:41:23     INFO -      @dom/animation/test/mozilla/file_restyles.html:152:3
20:41:23     INFO -      waitForPaints@SimpleTest/paint_listener.js:77:5
20:41:23     INFO -      waitForPaints/<@SimpleTest/paint_listener.js:65:22
20:41:23     INFO -      setTimeout handler*paintListener@SimpleTest/paint_listener.js:32:7
20:41:23     INFO -      EventListener.handleEvent*@SimpleTest/paint_listener.js:35:3
20:41:23     INFO -      @SimpleTest/paint_listener.js:1:2
Huh, so this failure also happens on non-Android platforms.
Flags: needinfo?(hikezoe)
Windows ccov is another very slow platform, like Android.
Thanks! That's a quite useful information.  Now I think I know the failure reason.   We presumably unthrottle the animations there since the test cases take sometimes over 200ms.
Assignee: nobody → hikezoe
Status: NEW → ASSIGNED
Flags: needinfo?(hikezoe)
The test actually took long but not over 200ms.  But still we observed one styles.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=7b2783985dce1eec657bed31be83544307de0371&selectedJob=184912379
I came up with an idea to avoid this kind of failures.  The idea is just setting 'overflow: hidden' style for body element.  This should work.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=e2c6aaf003f8d3a09876732af5d97bf9d2bc1284
Duplicate of this bug: 1470798
Comment on attachment 8988086 [details]
Bug 1471106 - Set overflow:hidden to body element to avoid accidentally unthrottling animations to update the overflow region.

https://reviewboard.mozilla.org/r/253354/#review260252
Attachment #8988086 - Flags: review?(bbirtles) → review+
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7ce13e62bc0e
Set overflow:hidden to body element to avoid accidentally unthrottling animations to update the overflow region. r=birtles
https://hg.mozilla.org/mozilla-central/rev/7ce13e62bc0e
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
You need to log in before you can comment on or make changes to this bug.