Closed Bug 1471181 Opened Last year Closed Last year

[Twitter] Rendering issue inside the Reply popup

Categories

(Core :: Web Painting, defect, P2)

61 Branch
defect

Tracking

()

VERIFIED DUPLICATE of bug 1472465
mozilla63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 + wontfix
firefox62 + verified
firefox63 + verified

People

(Reporter: Anca, Assigned: miko)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Affected versions]: 
- 61.0 (20180621125625)
- 62.0b3 (20180625141512)
- 63.0a1 (2018-06-25)

[Affected platforms]:
- Ubuntu 16.04 x64
- Windows 10 x64
- Windows 7 x32
- Mac OS 10.11

[Steps to reproduce]:
1. Go to https://twitter.com/
2. Click on the Reply button
3. Type something inside the Reply to [..] popup
4. Observe the Reply button inside the popup

[Additional steps]: 
- This issue seems to occur often if first, the Retweet popup is opened and closed, before step 2 is executed.

[Expected result]:
- The Reply button is clear, active and clickable.

[Actual result]:
- Most of the time the Reply button remains grey out, or partially grey out (see screenshots: https://drive.google.com/open?id=1FgQybQDWyYC_p-Y3tJzV-f5e7z4z7S8U and https://drive.google.com/open?id=19n9xxNeR1LJxFxBeItO9BqMMLjEmFuDD).

[Regression range]: 
- I will try to determine if this is a regression asap.

[Additional Notes]:
- This rendering issue doesn’t affect in any way the functionality of the Reply button, if hover over it, the  button is not grey out anymore.
- This behavior is intermittent.
Sounds like this is an issue where we may want to contact Twitter, might be a change on their end.
Using mozregression, I ended up to the following:

Last good revision: 0f807beef229718c015553bac09e4f638ca2add1
First bad revision: 665843c6cfd1a3049128597afbef8a68bcc1e086
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=0f807beef229718c015553bac09e4f638ca2add1&tochange=665843c6cfd1a3049128597afbef8a68bcc1e086
Component: Layout: View Rendering → Layout: Web Painting
Flags: needinfo?(mikokm)
Version: Trunk → 61 Branch
Anca, can you put the screenshots in this bug as attachments? Thanks!
Flags: needinfo?(anca.soncutean)
Assignee: nobody → mikokm
Priority: -- → P2
Attached image screenshot isuue.png
Flags: needinfo?(anca.soncutean)
Flags: needinfo?(mikokm)
Hey Miko, have you had a chance to look into this?
Flags: needinfo?(mikokm)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #5)
> Hey Miko, have you had a chance to look into this?

Not yet unfortunately. There was a work week last week, where this part of the code got a lot of changes. The upcoming transform flattening (bug 1462672), will cause almost a complete rewrite of the opacity flattening code, as they share a lot of functionality.

I will look into this on Monday.
Flags: needinfo?(mikokm)
Fixed in bug 1472465.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1472465
Target Milestone: --- → mozilla63
This is tracked in bug 1472465, where it looks like we have a fix which should land soon (later this week) in beta.
Anca, can you verify that this is fixed on Nightly and Beta now?
Flags: needinfo?(anca.soncutean)
Yes, the issue is no longer reproducible on Firefox 63.0a1 (2018-07-22) and Firefox 62.0b10 (20180719140244) under Windows 10 x64, macOS 10.13 and Ubuntu 16.04 x32.
Flags: needinfo?(anca.soncutean)
Glad to see this fix riding the 62 train. I think we can live with it for another month on 61, though.
You need to log in before you can comment on or make changes to this bug.