Unknown events appear in the Browser Console when skipping or continuing the about:welcome sign-in

VERIFIED FIXED in Firefox 62

Status

()

defect
VERIFIED FIXED
11 months ago
11 months ago

People

(Reporter: cmuresan, Assigned: ewright)

Tracking

({regression})

Trunk
Firefox 63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 unaffected, firefox62+ verified, firefox63 verified)

Details

Attachments

(2 attachments)

[Affected versions]:
- Firefox Nightly 63.0a1, Build ID 20180626220124
- Firefox Beta 62.0b3, Build ID 20180625141512

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Steps to reproduce]:
1. Start the browser and navigate to the about:welcome page.
2. Open the Browser Console (Ctrl/Cmd+Shift+J) and Click the "Skip this step" button.
3. Observe the Browser Console.

[Expected results]:
- No errors are displayed.

[Actual results]:
- "Unknown event: ["activity_stream", "event", "SKIPPED_SIGNIN"]" error is displayed.

[Notes]:
- The issue is also reproducible if you enter a valid email address and click "Continue". In this case the "Unknown event: ["activity_stream", "event", "SUBMIT_EMAIL"]" error is displayed
- Attached a screen recording of the issue.
Looks like the attachment didn't make it.
See Also: → 1438239
Flags: needinfo?(ewright)
Assignee

Updated

11 months ago
Flags: needinfo?(ewright)
Comment hidden (mozreview-request)
Assignee

Updated

11 months ago
Assignee: nobody → ewright

Comment 3

11 months ago
mozreview-review
Comment on attachment 8988188 [details]
Bug 1471523 - Update Events.yaml for about:welcome events.

https://reviewboard.mozilla.org/r/253444/#review260038

Thanks!
Attachment #8988188 - Flags: review?(usarracini) → review+
This will need to be uplifted to 62 so that we have telemetry for about:welcome

Comment 5

11 months ago
Pushed by usarracini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7870fcd62dde
Update Events.yaml for about:welcome events. r=ursula

Comment 6

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7870fcd62dde
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
(In reply to Ursula Sarracini (:ursula) from comment #4)
> This will need to be uplifted to 62 so that we have telemetry for
> about:welcome

Hi Ursula, please request the uplift to beta in this bug. Thanks!
Flags: needinfo?(usarracini)
I have verified that the issue is no longer reproducible on the latest Nightly build (63.0a1, 20180701220749) on Windows 10 x64, Mac 10.13.5 and Arch Linux x64. Now, the events appear as expected in the browser console when "browser.ping-centre.log" is set to "true".
Status: RESOLVED → VERIFIED

Updated

11 months ago
Iteration: --- → 63.1 - July 9
Comment on attachment 8988188 [details]
Bug 1471523 - Update Events.yaml for about:welcome events.

Approval Request Comment
[Feature/Bug causing the regression]: Events file was not updated to support telemetry events coming from about:welcome, and was therefore throwing an error
[User impact if declined]: No telemetry captured for about:welcome
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes (63.0a1, 20180701220749)
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Just adding an additional string to an events file, no new code logic
[String changes made/needed]: None
Flags: needinfo?(usarracini)
Attachment #8988188 - Flags: approval-mozilla-beta?
Comment on attachment 8988188 [details]
Bug 1471523 - Update Events.yaml for about:welcome events.

Fix for about:welcome telemetry, let's uplift for beta 7.
Attachment #8988188 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I have verified that the issue is no longer reproducible on the latest Beta built (62.0b7, Build ID 20180709172241) on Windows 10 x64, Mac 10.13.6 and Arch Linux x64.
You need to log in before you can comment on or make changes to this bug.