Closed Bug 1471705 Opened 2 years ago Closed 2 years ago

V61 hides Find in Page count display using Dark theme

Categories

(Toolkit :: Themes, defect, P2)

61 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- wontfix
firefox62 --- verified
firefox63 --- verified

People

(Reporter: loren, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180621125625

Steps to reproduce:

Received update to V61 yesterday


Actual results:

I use the official Dark Theme, because the lightweight themes do a lousy job of showing the Find in Page search controls. It was working great for me, but now with V61 the count of found items and the current position among them is practically invisible, almost black on black. See screenshot - would you notice the message above the yellow squiggle? With screen brightness all the way up today I can barely read it. Last night it took me a long time to notice it was even there. 


Expected results:

People keep messing with the brightness levels of these messages. I imagine someone with a light theme complained, so it got darker. You need to rethink how themes access the levels. Instead of brightness levels, maybe specify a percentage level between foreground and background, so dark themes can show "90%" as 90% white and light themes show the same 90% as 90% black?
Component: Untriaged → Theme
Blocks: 1418605
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Priority: -- → P3
Duplicate of this bug: 1473442
Priority: P3 → P2
The title of this bug is a little too restrictive and perhaps should be broadened.  It isn't just the DARK theme that's affected -- in fact the display is broken for *ALL* themes except DEFAULT.  Text is pretty much invisible on all themes, and very weak on standard LIGHT and DARK themes.

As I suggested in Bug #1473442, the implementation of PRIVATE mode in current releases (ie, since 61.0) somehow just forces a purple colour background regardless of theme.  Theme seems to have no effect on the search colour scheme in normal mode, and I suspect that PRIVATE mode doesn't expect a theme either and just uses its own purple background without considering the font text colour (light grey).  This makes the problem apparent on *ALL* themes (except DEFAULT) and obviously wreaks havoc on LIGHT and DARK too.

I propose for now rolling back implementation of the purple background, or correcting it to recognize the colour of the count display text.  Then try to come up with a backward-compatible style default that works with as many themes as possible.
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Component: Theme → Themes
Product: Firefox → Toolkit
Comment on attachment 8991632 [details]
Bug 1471705 - Fix findbar status text color for lightweight themes.

https://reviewboard.mozilla.org/r/256548/#review263644
Attachment #8991632 - Flags: review?(ntim.bugs) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/14f80a95187d
Fix findbar status text color for lightweight themes. r=ntim
https://hg.mozilla.org/mozilla-central/rev/14f80a95187d
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Flags: qe-verify+
Comment on attachment 8991632 [details]
Bug 1471705 - Fix findbar status text color for lightweight themes.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1418605
[User impact if declined]: see comment 0
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: no
[Why is the change risky/not risky?]: trivial fix
[String changes made/needed]:
Attachment #8991632 - Flags: approval-mozilla-beta?
Hi, i managed to reproduce this issue in the oldest versions of Firefox like 61 and 62 and compared to Nightly 63.0a1 (2018-07-20), there is a definite improvement on all Operating Systems : Windows, Mac OsX and Linux. I will mark this issue Verified as Fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Comment on attachment 8991632 [details]
Bug 1471705 - Fix findbar status text color for lightweight themes.

Thanks for the verification! 
Let's uplift this theme fix for beta 11.
Attachment #8991632 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Yeaaaaa!  Thanks.  (So we won't have to wait too long...)
Hi,
I've managed to reproduce this issue on an older version of Beta 62.0b10, Build ID:20180719140244 and compared to the latest version of Beta 62.0b11 Build ID:20180723144101, where the issue is solved. Checked on Win10 x64, Win 7 x 64, Mac OsX 10.13 and Ubuntu 18.04. I'll mark this issue as verified/fixed.
Duplicate of this bug: 1479994
I can confirm that the fix works in today's official release of FF v62.0 -- so great to have that counter back !!
You need to log in before you can comment on or make changes to this bug.