Closed Bug 1471737 Opened 2 years ago Closed 1 year ago

Intermittent browser/components/preferences/in-content/tests/browser_subdialogs.js | Uncaught exception - TypeError: doc.getElementById(...) is null

Categories

(Firefox :: Preferences, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 67
Tracking Status
firefox67 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: Gijs)

References

Details

(Keywords: intermittent-failure, Whiteboard: [fxperf:p1])

Attachments

(1 file)

Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=185238497&repo=autoland

https://queue.taskcluster.net/v1/task/IA1wXLZ4QLuupnLIgyMw6A/runs/0/artifacts/public/logs/live_backing.log

[task 2018-06-27T20:19:23.571Z] 20:19:23     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_subdialogs.js | overlay is not visible - "hidden" != "visible" - 
[task 2018-06-27T20:19:23.572Z] 20:19:23     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_subdialogs.js | inline styles should be cleared - "" == "" - 
[task 2018-06-27T20:19:23.572Z] 20:19:23     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_subdialogs.js | sub-dialog should be unloaded - "about:blank" == "about:blank" - 
[task 2018-06-27T20:19:23.575Z] 20:19:23     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_subdialogs.js | closing event should indicate button was 'null' - null == null - 
[task 2018-06-27T20:19:23.576Z] 20:19:23     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_subdialogs.js | should be 1 if accepted, 0 if canceled, undefined if closed w/out button - 0 == 0 - 
[task 2018-06-27T20:19:23.577Z] 20:19:23     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_subdialogs.js | dialog count should decrease by 1 - 0 == 0 - 
[task 2018-06-27T20:19:23.577Z] 20:19:23     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_subdialogs.js | stack children count should decrease by 1 - 1 == 1 - 
[task 2018-06-27T20:19:23.577Z] 20:19:23     INFO - Leaving test bound correct_width_and_height_should_be_used_for_dialog
[task 2018-06-27T20:19:23.578Z] 20:19:23     INFO - Entering test bound wrapped_text_in_dialog_should_have_expected_scrollHeight
[task 2018-06-27T20:19:23.578Z] 20:19:23     INFO - Buffered messages logged at 20:19:23
[task 2018-06-27T20:19:23.579Z] 20:19:23     INFO - waiting for subdialog DOMFrameContentLoaded
[task 2018-06-27T20:19:23.580Z] 20:19:23     INFO - Buffered messages finished
[task 2018-06-27T20:19:23.580Z] 20:19:23     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_subdialogs.js | Uncaught exception - TypeError: doc.getElementById(...) is null
[task 2018-06-27T20:19:23.581Z] 20:19:23     INFO - Leaving test bound wrapped_text_in_dialog_should_have_expected_scrollHeight
[task 2018-06-27T20:19:23.582Z] 20:19:23     INFO - Entering test bound dialog_too_tall_should_get_reduced_in_height
[task 2018-06-27T20:19:23.582Z] 20:19:23     INFO - waiting for subdialog DOMFrameContentLoaded
[task 2018-06-27T20:20:05.861Z] 20:20:05     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-06-27T20:20:05.863Z] 20:20:05     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_subdialogs.js | Test timed out - 
[task 2018-06-27T20:20:05.883Z] 20:20:05     INFO - GECKO(6118) | MEMORY STAT | vsize 2548MB | residentFast 386MB | heapAllocated 122MB
[task 2018-06-27T20:20:05.884Z] 20:20:05     INFO - TEST-OK | browser/components/preferences/in-content/tests/browser_subdialogs.js | took 45060ms
[task 2018-06-27T20:20:05.885Z] 20:20:05     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-06-27T20:20:05.887Z] 20:20:05     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_subdialogs.js | Found a tab after previous test timed out: about:preferences - 
[task 2018-06-27T20:20:05.952Z] 20:20:05     INFO - checking window state
https://wiki.mozilla.org/Bug_Triage#Intermittent_Test_Failure_Cleanup
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---

P2 according the blocked bug.

The failing subtest wrapped_text_in_dialog_should_have_expected_scrollHeight is highly timing sensitive. If you apply the patch from bug 1527712 it then fails 100% time with exactly the same error as this intermittent has been filed for.

It is NOT caused by functionality being broken with that patch [1], it's because the timing is shifted, the xul dialog load slows down a bit.

Apparently ContentTask.spawn calls the given test function too soon and the "desc" element is not yet found in the markup. This code is totally unknown to me, hence ni'ing some folks that have changed the test lately.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1527712#c7

Flags: needinfo?(scottcwwu)
Flags: needinfo?(florian)
Flags: needinfo?(dtownsend)
Flags: needinfo?(MattN+bmo)
Priority: P5 → P2

I don't know anything about this test. In bug 1527712 Gijs offered to help.

Flags: needinfo?(florian) → needinfo?(gijskruitbosch+bugs)
Flags: needinfo?(scottcwwu)
Flags: needinfo?(dtownsend)
Flags: needinfo?(MattN+bmo)
Assignee: nobody → gijskruitbosch+bugs
Status: REOPENED → ASSIGNED
Flags: needinfo?(gijskruitbosch+bugs)
Priority: P2 → P1
Whiteboard: [fxperf:p1]
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/495029aae21b
ensure DOMFrameContentLoaded events in browser_subdialogs.js are actually for the right frame before continuing the test, r=jaws
Status: ASSIGNED → RESOLVED
Closed: 2 years ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Thanks for fixing this so quickly, Gijs!

You need to log in before you can comment on or make changes to this bug.