Closed Bug 1471747 Opened 4 years ago Closed 4 years ago

Intermittent stylebench | invalid literal for float(): 6.23999999JavaScript error: http://localhost:49744/tests/webkit/PerformanceTests/Speedometer/resources/benchmark-report.js, line 50: TypeError: Argument 1 of Node.removeChild is not an object.

Categories

(Testing :: Talos, defect, P5)

Version 3
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1482043

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=185216036&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/B_4e7MORRNC4Qa5bv2enUg/runs/0/artifacts/public/logs/live_backing.log

17:58:49     INFO -  PID 5668 | [#50] Before and after pseudo elements/Removing leaf elements  Cycles:45  Average:32.63  Median:173.56  stddev:39.40 (22.7%)  stddev-sans-first:39.79
17:58:49     INFO -  PID 5668 | Values: 18.0  15.7  19.4  98.2  23.3  14.6  15.1  173.6  15.2  19.4  16.1  21.6  15.3  14.2  124.0  15.3  14.5  15.0  21.5  20.8  22.4  22.1  22.8  15.6  20.8  184.6  16.0  17.3  18.3  22.3  80.0  13.3  15.9  15.3  20.1  23.0  15.1  68.7  15.9  57.3  20.1  18.3  15.5  21.4  15.7
17:58:49     INFO -  PID 5668 |
17:58:49     INFO -  PID 5668 | [#51] Before and after pseudo elements  Cycles:45  Average:513.09  Median:509.10  stddev:102.49 (20.1%)  stddev-sans-first:102.61
17:58:49     INFO -  PID 5668 | Values: 609.3  381.0  362.9  401.6  388.9  405.7  585.3  569.5  584.9  638.8  503.9  606.2  500.3  490.7  597.2  381.1  509.1  588.5  601.0  347.6  497.6  628.7  626.8  389.3  358.7  620.3  595.3  458.1  453.3  590.8  385.0  462.6  670.6  495.8  696.4  637.7  557.2  430.6  328.0  410.3  622.4  529.4  574.7  437.0  579.0
17:58:49     INFO -  PID 5668 | -------- Summary: end --------
17:58:49     INFO -  PID 5668 |
17:58:49     INFO -  PID 5668 | [Parent 5668, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
17:58:49     INFO -  PID 5668 | [Parent 5668, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
17:58:49     INFO -  PID 5668 | [Child 3760, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
17:58:49     INFO -  PID 5668 | [Child 3760, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
17:58:49     INFO -  PID 5668 | [Parent 5668, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
17:58:49     INFO -  PID 5668 | [Child 4564, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
17:58:49     INFO -  PID 5668 | [GPU 1308, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
17:58:49     INFO -  PID 5668 |
17:58:49     INFO -  PID 5668 | ###!!! [Child][MessageChannel::SendAndWait] Error: Channel error: cannot send/recv
17:58:49     INFO -  PID 5668 |
17:58:50     INFO -  TEST-INFO | 5668: exit 0
17:58:50    ERROR -  TEST-UNEXPECTED-ERROR | stylebench | invalid literal for float(): 6.23999999JavaScript error: http://localhost:49744/tests/webkit/PerformanceTests/Speedometer/resources/benchmark-report.js, line 50: TypeError: Argument 1 of Node.removeChild is not an object.
17:58:50    ERROR -  Traceback (most recent call last):
17:58:50     INFO -    File "C:\Users\task_1530121665\build\tests\talos\talos\run_tests.py", line 297, in run_tests
17:58:50     INFO -      talos_results.add(mytest.runTest(browser_config, test))
17:58:50     INFO -    File "C:\Users\task_1530121665\build\tests\talos\talos\ttest.py", line 63, in runTest
17:58:50     INFO -      return self._runTest(browser_config, test_config, setup)
17:58:50     INFO -    File "C:\Users\task_1530121665\build\tests\talos\talos\ttest.py", line 270, in _runTest
17:58:50     INFO -      else None)
17:58:50     INFO -    File "C:\Users\task_1530121665\build\tests\talos\talos\results.py", line 97, in add
17:58:50     INFO -      results = browserLog.results()
17:58:50     INFO -    File "C:\Users\task_1530121665\build\tests\talos\talos\results.py", line 403, in results
17:58:50     INFO -      format_pagename=self.format_pagename)
17:58:50     INFO -    File "C:\Users\task_1530121665\build\tests\talos\talos\results.py", line 248, in __init__
17:58:50     INFO -      result['runs'] = [float(i) for i in r[2:]]
17:58:50    ERROR -  ValueError: invalid literal for float(): 6.23999999JavaScript error: http://localhost:49744/tests/webkit/PerformanceTests/Speedometer/resources/benchmark-report.js, line 50: TypeError: Argument 1 of Node.removeChild is not an object.
17:58:50     INFO -  TEST-INFO took 129639ms
17:58:50     INFO -  SUITE-END | took 379s
17:58:50    ERROR - Return code: 2
17:58:50  WARNING - setting return code to 2
17:58:50    ERROR - # TBPL FAILURE #
17:58:50     INFO - Running post-action listener: _package_coverage_data
17:58:50     INFO - Running post-action listener: _resource_record_post_action
17:58:50     INFO - [mozharness: 2018-06-27 17:58:50.954000Z] Finished run-tests step (success)
17:58:50     INFO - Running post-run listener: _resource_record_post_run
17:58:51     INFO - Total resource usage - Wall time: 385s; CPU: 24.0%; Read bytes: 220164608; Write bytes: 774032896; Read time: 5; Write time: 16
17:58:51     INFO - TinderboxPrint: CPU usage<br/>24.4%
17:58:51     INFO - TinderboxPrint: I/O read bytes / time<br/>220,164,608 / 5
17:58:51     INFO - TinderboxPrint: I/O write bytes / time<br/>774,032,896 / 16
17:58:51     INFO - TinderboxPrint: CPU idle<br/>2,328.8 (75.6%)
17:58:51     INFO - TinderboxPrint: CPU system<br/>110.6 (3.6%)
17:58:51     INFO - TinderboxPrint: CPU user<br/>638.8 (20.7%)
17:58:51     INFO - install - Wall time: 4s; CPU: 9.0%; Read bytes: 2048512; Write bytes: 68750848; Read time: 0; Write time: 2
17:58:51     INFO - setup-mitmproxy - Wall time: 0s; CPU: Can't collect data; Read bytes: 0; Write bytes: 0; Read time: 0; Write time: 0
17:58:51     INFO - run-tests - Wall time: 381s; CPU: 25.0%; Read bytes: 216141824; Write bytes: 703632896; Read time: 5; Write time: 14
17:58:51     INFO - Running post-run listener: copy_logs_to_upload_dir
17:58:51     INFO - Copying logs to upload dir...
17:58:51     INFO - mkdir: C:\Users\task_1530121665\build\upload\logs
17:58:52     INFO - Copying logs to upload dir...
17:58:52     INFO - Using _rmtree_windows ...
17:58:52     INFO - Running command: del /F /Q "C:\Users\task_1530121665\build\upload\logs\localconfig.json"
17:58:52     INFO - Return code: 0
17:58:52     INFO - Using _rmtree_windows ...
17:58:52     INFO - Running command: del /F /Q "C:\Users\task_1530121665\build\upload\logs\talos_info.log"
17:58:52     INFO - Return code: 0
17:58:52     INFO - Using _rmtree_windows ...
17:58:52     INFO - Running command: del /F /Q "C:\Users\task_1530121665\build\upload\logs\talos_raw.log"
17:58:52     INFO - Return code: 0
17:58:52     INFO - Using _rmtree_windows ...
17:58:52     INFO - Running command: del /F /Q "C:\Users\task_1530121665\build\upload\logs\talos_warning.log"
17:58:52     INFO - Return code: 0
17:58:52     INFO - Using _rmtree_windows ...
17:58:52     INFO - Running command: del /F /Q "C:\Users\task_1530121665\build\upload\logs\talos_critical.log"
17:58:52     INFO - Return code: 0
17:58:52     INFO - Using _rmtree_windows ...
17:58:52     INFO - Running command: del /F /Q "C:\Users\task_1530121665\build\upload\logs\talos_error.log"
17:58:52     INFO - Return code: 0
17:58:52     INFO - Using _rmtree_windows ...
17:58:52     INFO - Running command: del /F /Q "C:\Users\task_1530121665\build\upload\logs\talos_fatal.log"
17:58:52     INFO - Return code: 0
17:58:52  WARNING - returning nonzero exit status 2
[taskcluster 2018-06-27T17:58:52.194Z]   Exit Code: 2
[taskcluster 2018-06-27T17:58:52.194Z]   User Time: 0s
[taskcluster 2018-06-27T17:58:52.195Z] Kernel Time: 0s
[taskcluster 2018-06-27T17:58:52.195Z]   Wall Time: 10m55.562455s
[taskcluster 2018-06-27T17:58:52.195Z] Peak Memory: 6062080
[taskcluster 2018-06-27T17:58:52.195Z]      Result: FAILED
[taskcluster 2018-06-27T17:58:52.195Z] === Task Finished ===
[taskcluster 2018-06-27T17:58:52.195Z] Task Duration: 10m55.5760755s
There are 40 failures in the last 7 days.
They occur on windows7-32 (opt and pgo), osx-10-10 (opt), linux64 (opt and pgo).
Recent failure log (10.08.18): https://treeherder.mozilla.org/logviewer.html#?job_id=193284141&repo=mozilla-inbound&lineNumber=1732
:ebalaza_, you can see in the details this was fixed 2 days ago as there are no instances in the last couple days.  I am struggling to find the fix though
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1482043
You need to log in before you can comment on or make changes to this bug.